cancel
Showing results for 
Search instead for 
Did you mean: 

Usage RemoteSupport Components for SAP Web AS Java

hannover_sap-basis
Participant
0 Kudos

Hello,

it is possible to use RemoteSupport- Components for SAP Web AS Java or i have to use SolutionManager Diagnostics?

Best regards

Lutz

Accepted Solutions (1)

Accepted Solutions (1)

Toby_Johnston
Employee
Employee
0 Kudos

Dear Lutz,

Yes, functionally you should be able to monitor SAP Netweaver 7.10 Java stack with RSC SP2. However, although it should work, this platform is currently untested for RSC SP2 codeline. We are planning to include full support and testing for this platform in RSC SP3 codeline.

If you have further questions or issues regarding this please feel free to post here again.

Sincerely,

Toby Johnston

SAP America, Inc.

hannover_sap-basis
Participant
0 Kudos

Hello Toby,

it is possible to monitor SAP Netweaver 7.00 Java Stack with RSC SP3? You wrote that an implementation is planned.

Best regards

Lutz

Toby_Johnston
Employee
Employee
0 Kudos

Hi Lutz,

I have just finished documenting and testing SAP Netweaver instrumentation for RSC and it works great. Please follow these instructions.

[1654426|https://bcs.wdf.sap.corp/sap/support/notes/1654426] - How to instrument SAP Netweaver J2EE stack for Remote Support Component

Sincerely,

Toby Johnston

SAP America, Inc.

hannover_sap-basis
Participant
0 Kudos

Hello Toby,

on the managed host (Netweaver Java) I've done all steps, as described in Note 1654426.

From the point of "validate the installation" i have problems

Under the directory /usr/sap/CCMS/wily/ on the managed system unfortunately no log files were created.

could you please help me? Many Thanks

Lutz

Toby_Johnston
Employee
Employee
0 Kudos

Hi Lutz,

It sounds like a permissions problem. Can you confirm, what user account is your NW instance running under? Make sure this user account has read/write permissions to the /usr/sap/CCMS directory and all directories below this folder.

For example, go to the /usr/sap/CCMS/wily/logs directory and check security here. Does the NW user account have write permissions here? Please confirm.

Also, can you tell me which version of NW you are instrumenting?

Thanks,

Toby Johnston

SAP America, Inc.

hannover_sap-basis
Participant
0 Kudos

Hi Toby,

Thank you for your answer.

The user ej1adm has write permissions on the folder /usr/sap/ccms/wily/logs.

am1la096:ej1adm 92> pwd

/usr/sap/ccms/wily/logs

am1la096:ej1adm 93> id

uid=3038(ej1adm) gid=200(sapsys) groups=200(sapsys),201(dba),202(oper),203(sapinst),65432(sugroup)

am1la096:ej1adm 94> touch writetest

am1la096:ej1adm 95> ls -l

total 0

-rw-rr 1 ej1adm sapsys 0 2012-01-09 10:58 writetest

What do you mean with "Logon to InfoView to generate some performance data" (BusinessObjects Infoview)?

kind regards

Lutz

Henry_Banks
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi,

Toby means - "get some users to logon and work in infoview " - this will generate some system activity which should be captured by the probes and recorded as metrics.

regards,

H

Toby_Johnston
Employee
Employee
0 Kudos

Hi Lutz,

It looks like your permissions are ok. We need to check a couple more items to make sure the probe is loading ok.

1) What version of Netweaver are you using?

2) Were you able to successfully create the AutoProbeConnector?

3) Please send me the following file to toby.johnston @ sap.com or attach it to this post.

/usr/sap/<SID>/<instance>/j2ee/cluster/instance.properties

4) Did you restart the NW instance after making the configuration changes?

I will look forward to your response.

Thanks

Toby

hannover_sap-basis
Participant
0 Kudos

Hi Toby,

thanks for the quick response.

1) What version of Netweaver are you using? => I sent this information to your mail

2) Were you able to successfully create the AutoProbeConnector?

am1la096:ej1adm 60> cd /usr/sap/ccms/wily/connectors/

am1la096:ej1adm 61> java -jar CreateAutoProbeConnector.jar -jvm /usr/sap/EJ1/java

1/10/12 10:10:32 AM CET [INFO] [Creator] AutoProbe Connector Creation Utility Release 8.2.3.5 (Build 476583)

1/10/12 10:10:32 AM CET [INFO] [Creator] Using Java VM version "IBM J9 VM 1.4.2" from IBM Corporation

1/10/12 10:10:32 AM CET [INFO] [Creator] CA Wily Introscope(R) Version 8.2

1/10/12 10:10:32 AM CET [INFO] [Creator] Copyright (c) 2010 CA. All Rights Reserved.

1/10/12 10:10:32 AM CET [INFO] [Creator] Introscope(R) is a registered trademark of CA.

The AutoProbe Connector was successfully created at /usr/sap/ccms/wily/connectors/AutoProbeConnector.jar.

3) Please send me the following file to toby.johnston @ sap.com or attach it to this post. => I sent this Information to your mail

/usr/sap/<SID>/<instance>/j2ee/cluster/instance.properties

4) Did you restart the NW instance after making the configuration changes? => Yes, i have restart the NW instance.

Many Thanks

Lutz

Toby_Johnston
Employee
Employee
0 Kudos

Hi Lutz,

Thanks for the detailed response. I believe I have spotted the problem. In your instance.properties I see under "JavaParameters" the -Xbootclasspath/p: property contains three references and they are seperated by semi colons instead of colons. On Windows, this would be ok however on Unix you should be using colons instead of semi colons for the classpath delimeter.

1) Run the SAP J2EE Configuration Tool (configtool.bat)

2) Locate your NW instance

3) In the Java Parameters, locate the property -Xbootclasspath/p: and then change the semi colons to colons.

For example:

-Xbootclasspath/p:/usr/sap/ccms/wily/Agent.jar:/usr/sap/ccms/wily/connectors/AutoProbeConnector.jar:/usr/sap/ccms/wily/WebAppSupport.jar

4) Save the changes then restart your NW instance.

5) Logon to InfoView and run some reports then check for existence of logs under /usr/sap/wily/logs

I'll look forward to your reply.

Sincerely,

Toby Johnston

SAP America, Inc.

Toby_Johnston
Employee
Employee
0 Kudos

Hi Lutz,

Did you have a chance to try my suggestion? Let me know if you require any further assitance.

Thanks

Toby

hannover_sap-basis
Participant
0 Kudos

Hello Toby,

sorry for the late response.

when i set

-Xbootclasspath

-Dcom.wily.introscope.agentProfile

and -Dcom.wily.introscope.agent.agentName the JVM did not start because of the following errors.

/usr/sap/EJ1/JC38/work/stderr0

(24529) New Child Process created.

(24529) Starting local Command:

Command: jc.sapEJ1_JC38

pf=/usr/sap/EJ1/SYS/profile/EJ1_JC38_jiej138

[Thr 47916890704784] MtxInit: 30002 0 2

The java class is not found: com.sap.engine.offline.OfflineToolStart

The java class is not found: com.sap.engine.offline.OfflineToolStart

The java class is not found: com.sap.engine.offline.OfflineToolStart

The java class is not found: com.sap.engine.offline.OfflineToolStart

/usr/sap/EJ1/JC38/work/dev_server0

Exception in thread "main" java/lang/NoSuchMethodError: java/lang/ClassLoader.isReflectCacheEnabled()Z

at java/lang/Class.lookupCachedMethod (Class.java:1696)

at java/lang/Class.getDeclaredMethod (Class.java:559)

at sun/misc/Signal.handle (Signal.java:199)

at java/lang/Terminator.setup (Terminator.java:69)

at java/lang/System.completeInitialization (System.java:67)

at java/lang/Thread.<init> (Thread.java:125)

JVMJ9VM015W Initialization error for library jclscar_23(14): JVMJ9VM009E J9VMDllMain failed

</verbosegc>

[Thr 1084238144] *** ERROR => JHVM_LoadJavaVM: Cannot create Java VM (rc=-4) [jhvmxx_mt.c 558]

[Thr 1084238144] *** ERROR => Cannot load Java VM (server) (rc=-1) [jlnchxxi_mt. 752]

[Thr 1084238144] **********************************************************************

      • ERROR => Java VM initialization failed.

      • Please see SAP Note 943602 , section 'Java VM initialization issues'

      • for additional information and trouble shooting.

**********************************************************************

[Thr 1084238144] SigISetIgnoreAction : SIG_IGN for signal 17

[Thr 1084238144] JLaunchCloseProgram: good bye (exitcode = -1)

/usr/sap/EJ1/JC38/work/std_server0.out

Exception in thread "main" java/lang/NoSuchMethodError: java/lang/ClassLoader.isReflectCacheEnabled()Z

at java/lang/Class.lookupCachedMethod (Class.java:1696)

at java/lang/Class.getDeclaredMethod (Class.java:559)

at sun/misc/Signal.handle (Signal.java:199)

at java/lang/Terminator.setup (Terminator.java:69)

at java/lang/System.completeInitialization (System.java:67)

at java/lang/Thread.<init> (Thread.java:125)

JVMJ9VM015W Initialization error for library jclscar_23(14): JVMJ9VM009E J9VMDllMain failed

</verbosegc>

Could you please help me with this topic?

kind regards

Lutz

Toby_Johnston
Employee
Employee
0 Kudos

Hi Lutz,

It appears there is an issue with your booclasspath.

Can you attach the file /usr/sap/<SID>/<instance>/j2ee/cluster/instance.properties after making the requested changes?

There is likely a missing jar file or a typo which is causing the jvm to fail on startup.

Thanks

Toby

hannover_sap-basis
Participant
0 Kudos

Hi Toby,

attached the /usr/sap/<SID>/<instance>/j2ee/cluster/instance.properties after making the requested changes:

1 ID389508000.ClassPath=./bin/boot/boot.jar:./bin/system/bytecode.jar:.

2 ID389508000.Debuggable=no

3 ID389508000.JLaunchParameters=

4 ID389508000.JavaParameters=-Xms200M -Xmn70M -Xjvm:j9vm23 -Xthr:minimizeU

serCPU -Xgcpolicy:gencon -Xdump:system:events=systhrow,filter=java/lang/

OutOfMemoryError,request=exclusive+prepwalk -verbose:gc -Djava.security.

policy=./java.policy

5 ID389508000.JavaPath=/usr/sap/EJ1/java

6 ID389508000.LogName=dispatcher

7 ID389508000.MainClass=com.sap.engine.boot.Start

8 ID389508000.MaxHeapSize=200

9 ID389508000.Name=dispatcher

10 ID389508000.Parameters=

11 ID389508000.RootPath=/usr/sap/EJ1/JC38/j2ee/cluster/dispatcher

12 ID389508000.Type=dispatcher

13 ID389508050.ClassPath=./bin/boot/boot.jar:./bin/boot/jaas.jar:./bin/syst

em/bytecode.jar:.

14 ID389508050.DebugMode=no

15 ID389508050.DebugPort=53821

16 ID389508050.Debuggable=no

17 ID389508050.JLaunchParameters=

18 ID389508050.JavaParameters=-Xms2048M -Xmn400M -Xjvm:j9vm23 -Xthr:minimiz

eUserCPU -Xgcpolicy:gencon -Xdisableexplicitgc -Xdump:system:events=syst

hrow,filter=java/lang/OutOfMemoryError,request=exclusive+prepwalk -verbo

se:gc -Djava.awt.headless=true -Djco.jarm=1 -Dorg.omg.CORBA.ORBClass=com

.sap.engine.system.ORBProxy -Dorg.omg.CORBA.ORBSingletonClass=com.sap.en

gine.system.ORBSingletonProxy -Dorg.omg.PortableInterceptor.ORBInitializ

erClass.com.sap.engine.services.ts.jts.ots.PortableInterceptor.JTSInitia

lizer -Djavax.rmi.CORBA.PortableRemoteObjectClass=com.sap.engine.system.

PortableRemoteObjectProxy -Djava.security.policy=./java.policy -Djava.se

curity.egd=file:/dev/urandom -Xbootclasspath/p:/usr/sap/ccms/wily/Agent. jar:/usr/sap/ccms/wily/connectors/AutoProbeConnector.jar:/usr/sap/ccms/w ily/WebAppSupport.jar -Dcom.wily.introscope.agentProfile=/usr/sap/ccms/w ily/IntroscopeAgent.profile -Dcom.wily.introscope.agent.agentNmae=AAA_WA S_jiej138

19 ID389508050.JavaPath=/usr/sap/EJ1/java

20 ID389508050.LogName=server0

21 ID389508050.MainClass=com.sap.engine.boot.Start

22 ID389508050.MaxHeapSize=2048

23 ID389508050.Name=server0

24 ID389508050.Parameters=

25 ID389508050.RootPath=/usr/sap/EJ1/JC38/j2ee/cluster/server0

26 ID389508050.Type=server

27 bootstrap.ClassPath=./bootstrap/launcher.jar

28 bootstrap.JavaParameters=-Djco.jarm=1

29 bootstrap.JavaPath=/usr/sap/EJ1/java

30 bootstrap.MainClass=com.sap.engine.offline.OfflineToolStart

31 bootstrap.MaxHeapSize=256

32 bootstrap.Name=bootstrap

33 bootstrap.Parameters=com.sap.engine.bootstrap.Bootstrap ./bootstrap ID38

95080

34 bootstrap.RootPath=/usr/sap/EJ1/JC38/j2ee/cluster

35 bootstrap.Type=bootstrap

36 bootstrap_ID389508000.ClassPath=./bootstrap/launcher.jar

37 bootstrap_ID389508000.JLaunchParameters=

38 bootstrap_ID389508000.JavaParameters=-Djco.jarm=1

39 bootstrap_ID389508000.JavaPath=/usr/sap/EJ1/java

40 bootstrap_ID389508000.MainClass=com.sap.engine.offline.OfflineToolStart

41 bootstrap_ID389508000.MaxHeapSize=256

42 bootstrap_ID389508000.Name=dispatcher bootstrap

43 bootstrap_ID389508000.Parameters=com.sap.engine.bootstrap.Bootstrap ./bo

otstrap ID389508000

44 bootstrap_ID389508000.RootPath=/usr/sap/EJ1/JC38/j2ee/cluster

45 bootstrap_ID389508000.Type=bootstrap

46 bootstrap_ID389508050.ClassPath=./bootstrap/launcher.jar

47 bootstrap_ID389508050.JLaunchParameters=

48 bootstrap_ID389508050.JavaParameters=-Djco.jarm=1

49 bootstrap_ID389508050.JavaPath=/usr/sap/EJ1/java

50 bootstrap_ID389508050.MainClass=com.sap.engine.offline.OfflineToolStart

51 bootstrap_ID389508050.MaxHeapSize=256

52 bootstrap_ID389508050.Name=server0 bootstrap

53 bootstrap_ID389508050.Parameters=com.sap.engine.bootstrap.Bootstrap ./bo

otstrap ID389508050

54 bootstrap_ID389508050.RootPath=/usr/sap/EJ1/JC38/j2ee/cluster

55 bootstrap_ID389508050.Type=bootstrap

56 instance.box.number=EJ1JC38jiej138

57 instance.en.host=jiej138

58 instance.en.port=3292

59 instance.enabled=yes

60 instance.install.dir=/usr/sap/EJ1/JC38/j2ee

61 instance.ms.host=jiej138

62 instance.ms.port=3992

63 instance.osLibsPath=/usr/sap/EJ1/JC38/j2ee/os_libs

64 instance.runAction=NONE

65 instance.runMode=normal

66 instance.system.id=38

Many thanks

Lutz

Toby_Johnston
Employee
Employee
0 Kudos

Hi Lutz,

I'd like to verify the paths in your classpath. Can you logon to your unix terminal where NW is installed and execute the following commands?




file /usr/sap/ccms/wily/Agent.jar
file /usr/sap/ccms/wily/connectors/AutoProbeConnector.jar
file /usr/sap/ccms/wily/WebAppSupport.jar


Also, launch the configtool, go to your server instance and take a screenshot of all the properties. Attach this.

I did some checking and the class that is not found, "com.sap.engine.offline.OfflineToolStart" is located in launcher.jar and according to your instance.properties, it is in the classpath




ClassPath=./bootstrap/launcher.jar


I think the problem might be related to the autoprobeconnector.jar. Have a look at note [1149214|https://service.sap.com/sap/support/notes/1149214].

Can you confirm what JVM you are using and what operating system? We may need to recompile the auto probe connector again using this additional classes.jar.

I'll look forward to your response.

Thanks

Toby

Toby_Johnston
Employee
Employee
0 Kudos

Hi Lutz,

Now I see you are using the IBM JDK! You can forget my previous request.

Please rebuild the AutoProbeConnector.jar using the steps in note:

[1149214 - Wily Introscope Agent with IBM Java VM 1.4.2 (SR1x) x86_64|https://service.sap.com/sap/support/notes/1149214].

Then add the properties back to your xbootclasspath and try again. It should be working for you.

Sincerely,

Toby

Toby_Johnston
Employee
Employee
0 Kudos

Hi Lutz,

Did you have a chance to try the fix?

Cheers,

Toby

Former Member
0 Kudos

Hi

We are encountering the same problem with the same IBM Java, however we are using introscope agent 8.2 and are monitoring solman 7.1 it self.

Would the above solution be applicable for us also?

br

Toby_Johnston
Employee
Employee
0 Kudos

Hello,

Yes, if you are using the IBM J9 JDK you must generate the autoprobeconnector JAR containing that special runtime parameter referencing classes.zip.

It seems to be the case even with the later versions of IBM's JDK (not just 1.4)

Thanks,

Toby Johnston

SAP America, Inc.

Answers (0)