cancel
Showing results for 
Search instead for 
Did you mean: 

URL to call the Integration Server is missing on the sender system

Former Member
0 Kudos
745

Dears,

We have installed PI 7.1(ABAP+JAVA) server with Oracle on AIX.

In post configuration I have only performed only *Netweaver Inital set up*

Now my developer when start working,In tcode sxmb_admin->monitor Processed XML messages->

They are getting error:

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

- <!-- Call Integration Server

-->

- <SAP:Error xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1">

<SAP:Category>XIServer</SAP:Category>

<SAP:Code area="INTERNAL">INTEGRATION_SERVER_URL_MISSING</SAP:Code>

<SAP:P1 />

<SAP:P2 />

<SAP:P3 />

<SAP:P4 />

<SAP:AdditionalText />

<SAP:Stack>URL to call the Integration Server is missing on the sender system</SAP:Stack>

<SAP:Retry>M</SAP:Retry>

</SAP:Error>

Please suggest how can I solve this issue and also confirm if there is anything in configuration that is mandotry in PI 7.1

Shivam

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Mittal,

As prateek suggested you need to configure the integration engine. Please see this sap help:

http://help.sap.com/saphelp_nw04/helpdata/en/89/b5553bf3a76258e10000000a114084/content.htm

http://help.sap.com/saphelp_nw04/helpdata/en/41/b714f55ffc11d5b3ea0050da403d6a/content.htm

Also please do all the post configuration steps so that you dont run into any issues. Also once you are done try running SLDCHECK to see whether it has connection to sld. If you have any errors there you may need to do those configuration also.

Regards,

---Satish

Former Member
0 Kudos

Dear Satish,

Thanks for the reply.

I checked SLDCHECK is working fine,then plz suggest what are the mandotry configuration steps for PI 7.1.

Beside it also suggest this parameter IS_URL I should add in sender system or PI system as in Pi system it has already been set.

Please suggest.

Shivam

Edited by: Shivam Mittal on Sep 19, 2009 9:36 AM

Former Member
0 Kudos

Dears,

That error has been resolved but now I am getting error:

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

- <!-- Call Integration Server

-->

- <SAP:Error xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1">

<SAP:Category>XIServer</SAP:Category>

<SAP:Code area="INTERNAL">UNAUTHORIZED</SAP:Code>

<SAP:P1>401</SAP:P1>

<SAP:P2>Unauthorized</SAP:P2>

<SAP:P3>(See attachment HTMLError for details)</SAP:P3>

<SAP:P4 />

<SAP:AdditionalText />

<SAP:Stack />

<SAP:Retry>N</SAP:Retry>

</SAP:Error>

In the attached document I found error:

The call of the URL http://pidev:50000/sap/xi/engine was broken off due to incorrect dates of registration.

The registration was implemented in the system PD1. Here no dates of registration were made available.

If you have still no user identification, then you turn to your system administrator.

Please suggest.

Shivam

Edited by: Shivam Mittal on Sep 19, 2009 2:09 PM

prateek
Active Contributor
0 Kudos

In PI system goto transaction sxmb_adm -> Integration Engine configuration. There check what do have for role of business system as "Integration Server". You must have an HTTP destination present there or a URL I mentioned above. In case you have HTTP destination, make sure that an RFC destination with same name is present in sm59. If you have URl. make sure that the URL completely follows the same format.

Regards,

Prateek

former_member200962
Active Contributor
0 Kudos

You are getting this erro because of incorrect user credentials.

Ensure:

1) The Usre-id and passeord that you are using is correct and has enough authorizations to carry out the end-to-end testing

2) The user who is doing the testing is in the validity period (we recently faced the above authorization problem and the reason was due to pt.2 )

3) The user is not locked.

Regards,

Abhishek.

Former Member
0 Kudos

Hi,

Please goto transaction SPROXY.

There is a button called connection test. It will tell you what exactly needs to be done.

Regards,

Vikas

francis21
Participant
0 Kudos

Hi Shivam,

Were you able to resolve the <SAP:Code area="INTERNAL">UNAUTHORIZED</SAP:Code> error? How did you solve it?

Thanks,

Francis

Former Member
0 Kudos

Good day,

I am receiving the same error in PI. I am sending an XML document to update value mapping through HTTP from SAP to PI. But I keep getting the same error. Does anyone know the solution to this issue?

Error:

<SAP:Error><SAP:Category>XIServer</SAP:Category><SAP:Code>INTERNAL.UNAUTHORIZED</SAP:Code><SAP:P1>401 </SAP:P1><SAP:P2>Unauthorized</SAP:P2><SAP:P3>(See attachment HTMLError for details)</SAP:P3></SAP:Error>

Regards,

Chris C.

prateek
Active Contributor
0 Kudos

Goto sxmb_adm -> Integration Engine Configuration -> Specific Configuration. There you need to add IS_URL parameter with the following value

http://<XIHostName>:<HTTP_PORT>/sap/xi/engine?type=entry

I would suggest to complete post installation activities first. This is part of such activity.

Regards,

Prateek