Showing results for 
Search instead for 
Did you mean: 

URL Access to Main Controller : Cursor in the Input field not enabled

0 Kudos


I created BSP application with views and Controllers, when I am accessing the Application by using the URL of Main controller (Added as Favorite) , it was rendering the correct output , But the cursor is disabled I'm not able to give any input values.

My initial screen will be with

5 input values

1 Push button

After getting the output with disabled cursor then I clicked on the Push button , then the screen is refreshed and the input field is enabled for giving input values

Please let me know why the cursor is disabled on any of the five input fields when I run it first time using the main controller URL.

Why the cursor was enabled when I Execute any action (Cliking the push button) on the output screen

Pls help me what I'm missing

Pls note : if I'm executing it from SE80 it was giving several controller options to run when I double cliked the Main controller it was running fine ( cursor on the input field is enabled)

Thanks in advance

Warm regards

BMS Rajasekhar

Accepted Solutions (0)

Answers (2)

Answers (2)

0 Kudos

solved by me

Developer Advocate
Developer Advocate
0 Kudos

OK that sounds just plain wierd. There is no reason I can think of why the cursor should be disabled. That kind of thing takes JavaScript.

Are you using Delta Handling? If so try turning it off. I've never seen it cause this situation but it can cause other strange things.

Did you use the xhtmlb:protectDoubleSubmit in your view layout? If so there could be something strange with it. Try removing it as a test.

Other than those two ideas I can't come up with any reasonable explaination for this. Are you testing in IE or Firefox? You might try switching to the other to see if the problem is browser specific.