cancel
Showing results for 
Search instead for 
Did you mean: 

urgent: enhancement problem

Former Member
0 Kudos

hi all,

i am enhance the structure MC13VD0ITM, for the field of MARA-LABOR. Write the necessary code. activate. finally i am going to activate the update rule all the datasource are deactivate. i am found all the datasoruce assign for the cube 0SD_C03 2LIS_11... & 2LIS_12 ALL the datasoruce f0und THE CHARACTERISTICES MATALKT : rountine fields is empty ...

there write for all the datasouce any routin ?

or given constant but source char : is not found(zmaltkt)

if any routine is require what is the routin for all the datasoruce.

Thanks in advance

Regards

sangram sutar

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

I don't understand you very well. If you enhance structure MC13VD0ITM, only rules from MC13VD0ITM should have in count the new field. If you have added a new field to cube 0SD_C03, or any cube, always every update rule is deactivated. You can create a routine for updating the new field in every update rule, if you want, else only reactivate update rules for all data sources.

Former Member
0 Kudos

hi all,

i am add the infoobjcet zmatalkt in the cube now every datasoruce is deavtivate, how i am activate all the datasoruce .

2lis_11_vahdr = datasource

DATA: IN TYPE F,

OUT TYPE F,

DENOM TYPE F,

NUMER TYPE F.

DATA: DEB_CRED(2) TYPE C VALUE 'HK'.

DATA: QUOT(1) TYPE C VALUE 'B'.

  • result value of the routine

RESULT = ???????????????.

  • if the returncode is not equal zero, the result will not be updated

RETURNCODE = 0.

  • if abort is not equal zero, the update process will be canceled

ABORT = 0.

Former Member
0 Kudos

Create only the routine for the update rule where you wanted to update the new field. Don't create the routine for every rules if you can not provide a logic for fill in it, give the new field as not asigned and activate them.

Former Member
0 Kudos

Hi Sangram

As your response above and I referred to Priya's post

I hope that I understood your problem correctly.

You have added info object zmatalkt -> Fine.

The corresponding field will be available through only 1 data source 2LIS_13_VDITM (other datasources doesn't have that field).

First for update rules from 2LIS_13_VDITM to 0SD_C03-> do the mapping of zmatalkt to zmatalkt (select from infosurce 2LIS_13_VDITM/do F4) and activate the update rules.

For all other infosources, leave the mapping of zmatalkt to blank and activate the update rules.

Hope this helps

Regards

Pradip

Former Member
0 Kudos

hi all,

i am activate only wlis_13_vditm but other datasoruce are dclk all the keyfigure are red in color. i am going to deatail-> key figure cals, chareterstics ,time Ref-> characterstics-> field i am found zmatalkt field -> there is routine is found for the field.

i am before given constant for the fiels "-" all the output "-". than what i am write the code for all the datasoruce. please give me the valuable solution.

thanks & best regards]

sangram

Former Member
0 Kudos

Hi Sangram

For update rules from other datasources,

deatail-> key figure cals, chareterstics ,time Ref-> characterstics-> zmatalkt -> click on routine button -> here you choose the option as Initial value and then save & activate. Now the update rules will be activated.

Regards

Pradip

Former Member
0 Kudos

Hi All,

i am assign all the datasource in charaterstics = initial value but in the cube the value is found that "0".

any one suggest me in enhancement how to solve this type of issue.

regards

sangram

Former Member
0 Kudos

Hi Sangram

I had advised you following -

First for update rules from 2LIS_13_VDITM to 0SD_C03-> do the mapping of zmatalkt to zmatalkt (select from infosurce 2LIS_13_VDITM/do F4) and activate the update rules.

When you load the data from 2LIS_13_VDITM -> the values for field zmatalkt will be populated since you have done the mapping in update rules.(Check in PSA- if you are getting values for field zmatalkt)

For all other infosources, leave the mapping of zmatalkt to blank and activate the update rules.

When you load the data from these other datasources -> the values for field zmatalkt will be0 zero since you have Not done the mapping in update rules.

Please follow this and your problem will be solved.

Regards

Pradip

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi Sangram

You have written "ALL the datasoruce f0und THE CHARACTERISTICES MATALKT : rountine fields is empty ...

" ....

Can you please tell me which characteristic you are talking about?

Regards

Pradip