cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade SYBASE ASE from 15.7 to 16.0

indrajith_v
Participant
0 Kudos

Hello , please help here... we had started our upgrade for 15.7 Business Suite -->  16.0 Business Suite by following 2162735  . But we have used a general 16.0 ASE dump instead of 16.0 Business Suite.  later after realizing that we had downloaded wrong software we downloaded new 16.0 BS version .. then I have upgraded according to note-2162735  with 16.0 BS . in ASE suite Log I have seen that there were no errors. ENV variables automatically changed to 16.0.. but when I see the version using the command --> select @@ version .. I still see as 15.7. what else should be done.???

Accepted Solutions (1)

Accepted Solutions (1)

former_member198560
Active Participant
0 Kudos

Hi Indrajith,

have you performed the Post Installation tasks, like running the installmaster script from "/SYBASE/ASE-16-0/scripts/installmaster".

Please connect to server using isql and check the sp_version output if it shows the latest version.

~Gaurav

indrajith_v
Participant
0 Kudos

Hello gaurav, Thanks for your reply. All the env variables are now pointing to 16.0 version only. Below is the output of the command Sp_version .. we had done for all the scripts we found in the Scripts folder. ODBC MDA Scripts         15.7.0.1330.1014/Tue Mar 31 UTC 02:54:26 2015         Complete OLEDB MDA Scripts         15.7.0.1330.1014/Tue Mar 31 UTC 20:15:33 2015         Complete installcommit         16.0 SP01 PL03/EBF 24828 SMP/P/X64/Windows Server/ase160bw/3875/64-bit/         OPT/Fri Jan 15 20:47:48 2016         Incomplete installdbccdb         16.0 SP01 PL03/EBF 24828 SMP/P/X64/Windows Server/ase160bw/3875/64-bit/         OPT/Fri Jan 15 20:47:48 2016         Incomplete installdbextend         16.0 SP01 PL03/EBF 24828 SMP/P/X64/Windows Server/ase160bw/3875/64-bit/         OPT/Fri Jan 15 20:47:48 2016         Incomplete installjdbc         jConnect (TM) for JDBC(TM)/1002/Sun Sep 13 00:00:00 2015 PDT         Complete installjsdb         16.0 SP01 PL03/EBF 24828 SMP/P/X64/Windows Server/ase160bw/3875/64-bit/         OPT/Fri Jan 15 20:47:48 2016         Incomplete installmaster         15.7/EBF 25122 SMP SP136 /P/X64/Windows Server/ase157sp136x/3956/64-bit         /OPT/Mon Oct 26 02:32:13 2015         Complete installmodel         16.0 SP01 PL03/EBF 24828 SMP/P/X64/Windows Server/ase160bw/3875/64-bit/         OPT/Fri Jan 15 20:47:48 2016         Incomplete installsecurity         16.0 SP01 PL03/EBF 24828 SMP/P/X64/Windows Server/ase160bw/3875/64-bit/         OPT/Fri Jan 15 20:47:48 2016         Incomplete montables         15.7/25122/P/X64/Windows Server/ase157sp136x/3956/64-bit/OPT/Mon Oct 26         09:31:00 2015         Complete Please help. Thanks in advance.

former_member198560
Active Participant
0 Kudos

I can see installmaster showing as below :

installmaster         15.7/EBF 25122 SMP SP136 /P/X64/Windows Server/ase157sp136x/3956/64-bit         /OPT/Mon Oct 26 02:32:13 2015         Complete

Can you please check with running the installmaster script manually once again from "/SYBASE/ASE-16-0/scripts/installmaster".

Please check the sp_version output again after the installmaster finished.

~Gaurav

indrajith_v
Participant
0 Kudos

Every Script is returning me the below error:::::::::

'installcommit' is being run on an older ASE installation. ASE version '15700', install scripts version '16000'. CT-LIBRARY error:         ct_results(): network packet layer: internal net library error: Net-Libr ary operation terminated due to disconnect

(return status = 0) (1 row affected) 'installmodel' is being run on an older ASE installation. ASE version '15700', install scripts version '16000'. CT-LIBRARY error: ct_results(): network packet layer: internal net library error: Net-Library operation terminated due to disconnect

(1 row affected)

'installmaster' is being run on an older ASE installation. ASE version '15700', install scripts version '16000'. CT-LIBRARY error: ct_results(): network packet layer: internal net library error: Net-Library operation terminated due to disconnect



Please Help.


Thanks in advance.

former_member198560
Active Participant
0 Kudos

Can you please check the value set for environment variable "SYBASE_ASE" as :

echo $SYBASE_ASE

Please also provide the complete ASE server errorlog file.

indrajith_v
Participant
0 Kudos

hello Gaurav,

Thanks for your reply.

OK. now I have set the environment variable to -->echo $SYBASE_ASE. previously it was marked to ASE-16_0

Complete ASE server Log file??? Do you mean ASE_SUite.log

please let me know which log you are Asking about.

Thanks,

Indrajith

former_member198560
Active Participant
0 Kudos

Hi Indtajith,

On windows , The environment value can be checked using set command.

You can check the value set for SYBASE_ASE. This should point to ASE-16_0.

Please check as below :

set SYBASE_ASE

Please also provide us the ASE server logs from "/Sybase/SID/ASE-16_0/install/SID.log"
.

~Gaurav

indrajith_v
Participant
0 Kudos

Hello Gaurav,

thanks for your reply.

Yes the ENV variable is pointing to ASE-16_0.

but the log which you have mentioned is not there in that folder. . complete Install directory is empty.

what does that mean????

please Help.

Thanks

Indrajith.

former_member198560
Active Participant
0 Kudos

It seems there is some issue with the upgrade itself. Can you please check and provide the ASE Upgrade logs.

Can you please check with restoring the ASE server to the Older version and then perform the upgrade again following the SAP Note 1982469 - SYB: Updating SAP ASE with saphostctrl / sapdbctrl .

~Gaurav

indrajith_v
Participant
0 Kudos

Okay.

can you brief about what is restoring Procedure to older version.

Thanks.

indrajith_v
Participant
0 Kudos

what is the standard process of restoring . any blog or note or guide can you suggest.
Please Help.

Thanks

Indrajith.

former_member198560
Active Participant
0 Kudos

Indrajith,

I think, You should be able to restore from OS / Filesystem level backup along with data devices taken before the upgrade activity started.

~Gaurav

Answers (0)