cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade NetWeaver portal 7.4

Former Member
0 Kudos

Hi gurus,

We are planning to do upgrade EP 7.4 or 7.31

    

I checked ECC EHP7 (base on NW 7.4) can’t communicate with lower version (under NW 7.3).

We are using ECC 7.01 (EHP4) with portal 7.0, can I do
upgrade portal 7.4 with ECC EHP4?

If we want 7.4, we have to upgrade ECC EHP6 or EHP7?

Please give your advice.

Accepted Solutions (1)

Accepted Solutions (1)

Reagan
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hello

Please make use of the UDA tool to analyse whether the target release of EP is compatible with the present version of ECC system.

http://service.sap.com/uda

I just did a quick check and it says it is possible to upgrade EP to release 7.4 without upgrading the ECC system.

Regards

RB

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi,

When you use Solution manager to generate the XML with you ECC6 EHP4 and NW 7.01 Java system..

As you will have erp components deployed on the portal ,solution manager will generate the target stack as EHp7 for ECC and the NW 7.4 for the Java side...

If you dont want to upgrade your backend system you can go on to the NW 7.3X system..

In that case you need to just generate the stack file for Java and use the upgrade option for portal....

If you have ESS/MSS patch deployed on the portal you will have to go to 633 patch for ESS as 600 is not compatable with Older release..

U can use the UDA tool to go check the dependency.

But in the PAM it shows that the EHP4 is compatable as Add-on with Nw 7.4.....

Thanks

Rishi Abrol

Former Member
0 Kudos

Hi Rishi,

Thank you for your information however, I am not clear what you were saying.

ESS 600/633 (??) It means if I do portal upgrade 7.3x or 7.4, also ESS upgrade together?

ESS update is not part of portal upgrade? Do I need addtional steps?

My original question was if I do upgrade portal 7.4, is that compatible with ECC 6.04?

You said "in the PAM EHP4 is compatible as Add-on with NW 7.4" what does mean add-on?

Jerry S

Reagan
Product and Topic Expert
Product and Topic Expert
0 Kudos

My original question was if I do upgrade portal 7.4, is that compatible with ECC 6.04?

I already pointed out what you need to check to get the answer.

When I checked the UDA the answer I got is :

No known upgrade dependencies, independent upgrade possible

Regards

RB

Former Member
0 Kudos

Thank you again your reply,

I already checked UDA and there said possibly some restrictions

Reagan
Product and Topic Expert
Product and Topic Expert
0 Kudos

Could you tell me what exactly you selected for the source and the target system ?

Regards

RB

Reagan
Product and Topic Expert
Product and Topic Expert
0 Kudos

Here is what I could see.

Regards

RB

Former Member
0 Kudos

Hi,

Our backend system is using only ABAP.

We are using some java environmets, such as Web Dispatcher, TREX, Solman and EP

I would like to know if I do upgrade NW portal 7.4, what I have to do with our entire java environments and abap environments?

For instance, If ECC EHP7(backend) upgrade, I need to all of connected system upgrade to NW 7.3x or higer. My question is when we upgrade connected system, what about backend system?

Anyone can make answer?

Reagan
Product and Topic Expert
Product and Topic Expert
0 Kudos

What matters is the systems connected with the one which is planned to be upgraded.

You don't need to upgrade all the systems in the company just because you are upgrading one landscape.

Eg: An SAP BW system connected with an ECC system.

      An SAP SCM system with the LiveCache database.

It all depends on the role played by the second system.

Regards

RB

Former Member
0 Kudos

Hi Reagan,

I understood what you are saying however, I need evidence and proof doc or information to decide what version we are going to go.

I am still looking and searching but I didn't find yet.

regards

Former Member
0 Kudos

There was a similar discussion thread recently.

Former Member
0 Kudos

Hi Samuli,

I read that discussion yesterday and I am not clear what exalty that sap note saying (Note 1874939)

You use SAP Business Suite applications that are based on an Application Server Java ---- What products? We don't have any Bussiness Suite for Java.

and on hub systems such as Enterprise Portal Hub, BW Hub, or PI Hub.

If you know what are they?

Reagan
Product and Topic Expert
Product and Topic Expert
0 Kudos

I understood what you are saying however, I need evidence and proof doc or information to decide what version we are going to go.

How can I provide a proof to the version you want the system to be upgraded to?

Only you know what version you want the target version to be.

You can identify the possible impact on other systems with the help of tools like UDA and upgrade guide information.

I am trying to help you with the possible impact on the systems that are connected to the system that is planned to be upgraded.

You need to first get the upgrade guide and read it.

The upgrade guide is the bible you need to follow.

It has several SAP notes mentioned for you to read.

The upgrade guide is updated whenever required.

You need to understand what, how and the interoperability of the systems connected.

Regards

RB

Former Member
0 Kudos

Look at the matrix in the attachment of SAP note 1874939. Even in case of ESS / MSS (XSS) your landscape meets the requirements (EHP4 FOR SAP ERP 6.0 / NW 7.01) for a NW 7.4 hub system Technology Upgrade. Be sure to select at least NW 7.4 SP2 in while generating the stack XML in MOPZ, SP5 is the newest.

Former Member
0 Kudos

Hi Reagan,

I don't want to explain everything to you. I am not a decision maker. I am looking and searching what sort of risks if we go EP 7.4 or 7.3x with our environments. Your help was very thankful but you don't have to write like that. You think I didn't read install and master guide? Your reply wasn't that look good

Former Member
0 Kudos

Hi,

That XSS was very helpful and I already made action item in check lists.

If we go 7.4 it could be SPS05. But I am not sure with 7.4.

Regards.

Reagan
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hello Jerry

The main reason why the UDA tool is there is to analyse the risks involved (to an extend) in an SAP system upgrade task.

Secondly only you know or the company you work with knows what the EP is used for.

If the EP is connected with other SAP systems then you need to make use of the UDA tool.

To the best of my knowledge there is no dependency involved.

So my answer should be go ahead with the upgrade.

The only thing that I will bother to cross check is the support for the OS and DB for the upgrade activity.

Regards

RB