cancel
Showing results for 
Search instead for 
Did you mean: 

update SAP Program Variant values from Redwood.

0 Kudos

Hi, I am trying update variant from Redwood, i copied SAP_StoreVariant job and created another one then trying to enter one parameter so i can change only that alone.

I also imported related program and variant.

The variant value i am able to edit when i go maintain objects and edit the value and then trigger storevariant job. But when i duplicate storevariant and enter the parameter and add values its not working.

This is variant value in maintain objects.  (Pic Variant_1.jpg)

I added the param in the custom variant store i created as: (custom Variant.jpg)

Can someone please correct me if i am using wrong Parameters.

Thank you,

Arun

Accepted Solutions (1)

Accepted Solutions (1)

gmblom
Active Contributor
0 Kudos

Hello,

There is quite some documentation on this topic. Read into that as well.

You can try [201602 - 201605]

You need the brackets, and also the spaces are important here, otherwise -3 will be passed.

Regards Gerben

0 Kudos

Hi Gerben,

Following help documentation i used this option but its not working. Its not updating.

I tried [201602 - 201605] which did not work and i also tried [2016/02 - 2016/05] which also is not updating the variant.

Both did not work.

It works when i update the values in maintain objects and then trigger SAP_Store_Variant but when i copy the store variant job and customize it, its not working.

Thank you,

Arun

gmblom
Active Contributor
0 Kudos

Hello,

Make sure to remove the parameter from the Maintain Objects for this variant.

Also you probably have to rename your parameter to SEL_SPMON


Regards Gerben

0 Kudos

After I removed the parameter from Maintain Objects and ran with SEL_SPMON with value [201602 - 201605], it blanked the previous values also in SAP.

After adding back the parameter to Maintain objects it worked for the value in this but not from the custom variant job.

Thank you,

Arun

gmblom
Active Contributor
0 Kudos

Hello,

You have to make sure you get the parameter name right. From the first screenshot I can see that the variant parameter is S_SPMON. Therefore the Redwood parameter must be SEL_S_SPMON.

Regards Gerben

0 Kudos

Thank you Gerben, this is where i have done wrong. Thank you so much.

Thank you,

Arun

Answers (0)