cancel
Showing results for 
Search instead for 
Did you mean: 

Unsupported engine Node version error in Business Application Studio SAP BTP Cloud Foundry

Prasanna7
Explorer
490

Hi All,

Getting below error when I build node js app based on tutorial.

Tutorial link https://developers.sap.com/tutorials/build-apps-cap-service.html 

.npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE package: '@sap/xsenv@3.4.0',
npm WARN EBADENGINE required: { node: '^10.0.0 || ^12.0.0 || ^14.0.0 || ^16.0.0 || ^18.0.0' },
npm WARN EBADENGINE current: { node: 'v20.12.0', npm: '10.5.0' }
npm WARN EBADENGINE }

Not able to downgrade node version.

 

 

View Entire Topic
junwu
Active Contributor

in the package.json, change version of @Sap/xsenv to newer one, 5.1.0

Prasanna7
Explorer
0 Kudos
Thank you, I am still getting same error after updating in package.json file.
junwu
Active Contributor
0 Kudos
did you run npm install after change the package.json