Showing results for 
Search instead for 
Did you mean: 

Unknown Error: PDF_TEST_00 not returned Responds

Former Member
0 Kudos

Hi Gurus,

I am trying to execute some AIF using the T Code: FMBB, but just before calling the form itself, my testing program got stuck and does not longer respond. No messages, no outputs, nothing after that.

Have been to all of the step in this link: (Adobe Document Services

-Others steps I have done so far: Checking the IIOP Service and the Startup Properties

- I execute the Report FP_TEST_00.

Here is when it all comes, run the report, choosing a printer up to the

Parameters for printing AIF(Device Type: Post2) then I got a never-ending wait

cursor so the system is not longer responding. No Errors, no output, nothing at all.

I come to check the other test to resolve the error, according to the guide:

1. Checking the ABAP Connection:

execute the report FP_PDF_TEST_00

so good!, the report shows the version number of the Adobe document services as the guide says.

2. Checking the User and Password:

Server : dr6server.

J2EE Instance : 03.

Port : 50300.


URL = http://dr6server:50300/AdobeDocumentServices/Config

Enter the URL in Web browser and Choose rpdata(test.…)., enter the ADSUser and

password and the system displays the version number of the Adobe document

services in the response area, test successful!

3. Checking the Destination Service and the ICF Service


- Here the problem comes again, I just run the report above then got no respond at all. I could

Identify the line code where it does not continue:

l_soapresponse = adsobject->run( ).

- Apparently there are problems with the configuration of ADS, although already set ADS_AGENT with his role SAP_BC_FP_ICF, ADS_User with his role ADS_CALLERS, FP_ICF_DATA_ <SID> already been created in J2EE , install and configure the credentials of ADOVE successfully, the HTTP connection(RFC Destination 'ADS') was created successfully , and check the ICF in browser and the visual j2ee administrator and a test was successful only lacking in AS ABAP that gives me the error.

- Configuration of the Web Service for Basic Authentication have been use as step by step guide

configuration But the problem with the reports:


Can anyone please explain me where and how should I set the ADS to make this test successful.

Thanks in advance


Accepted Solutions (0)

Answers (1)

Answers (1)

0 Kudos

Hello Miquel,

When you run the report: FP_CHECK_DESTINATION_SERVICE and don't check the checkbox "with destinationservice", do you get any response (the response is a information message which says: xxxx bytes transferd)?

Let assume this works and when you check the ckeckbox and execute the report i doesn't work, please start the Visual Administrator and logon to the server where the ADS is running. Expand the tree "Services" and find the entry "Destinations". In the screen on the right side expand the "HTTP" map. Is there an entry? If not you should create one (for details take a look at page 21 of the ADS Configuration Guide).

After you create one, please try again.

I hope it helps. If you encounter more problems, let me know.

Kind regards,


Former Member
0 Kudos

Hey Miguel,

Also see if the printer type for adovbe forms has been set up properly in R/3.

Thanks and Regards,

Antony John Isacc.

Former Member
0 Kudos

Hello Maarten ,

first of all thank you for your quick reaction.

I run the program both ways, but there is no single answer falls into a cycle as infinity,

The service was created in the visual Administrator previously said that according to what the guide configuration, in the visual amdministrador -> Services -> Destinations. I introduced FP_ICF_DATA_DRA (ID system is DRA).

assign a name = "DR6SERVER" and port = "8003" which I found in the T-code SICF, authentication Basic client = "300" user = ADS_AGENT and passw (previously established with AS Abap Role = "SAP_BC_FP_ICF" probe save and test and the response was "GET HTTP response code 200" Test success.

but still not responding the report.

even probe "http://DR6SERVER:8003/sap/bc/fp/form/layout/fp_test_00.xdp"

both in the Administrator visual-> Services -> Destinations and in the browser and generates response.

Do you have another ideas solving my problem?

Thanks in advance



Former Member
0 Kudos

hello Anto,

thanks for your help,

I configure the printer, I made a copy of another kind and assigned type POST2 but still my problem.

Do you have another ideas solving my problem?

Thanks in advance