cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to Test Proxy Bridge for Document Service

0 Kudos
265

Hi All,

We have build Proxy Bridge for Document Service. Based on the Help guide provide https://help.sap.com/viewer/b0cc1109d03c4dc299c215871eed8c42/Cloud/en-US/ed1c6732d4214c68846ab9813b9...

But while access the Url for testing the service https://cmisproxy(subaccount).us3.hana.ondemand.com/cmisproxy/cmis/json

Getting below error message:

{"exception":"permissionDenied","message":"Config entry with unique name XXXXXXXX(Document RepositoryName ) is not allowed to be accessed"}

Need gudiance.

Thanks,

Chakravarti Gupta.

Accepted Solutions (1)

Accepted Solutions (1)

WouterLemaire
Active Contributor
0 Kudos

Just like Matteo, I was also able to follow the steps of SAP help in the past. I also kept the version of the proxy on my GitHub account, you can have a look: https://github.com/lemaiwo/NEODocumentServiceProxy

Kr, Wouter

0 Kudos

Hi Wouter,

Thankyou for sharing the Git Project. That helped resolving the issue. Sorry for late reponse.

Regards, Chakravarti Gupta

Answers (1)

Answers (1)

mconvertino
Explorer
0 Kudos

Hi,

I have followed the Help documentation myself in the past without problems. Can you confirm that the URL you are accessing is the same Application URL that you can find within the cockpit of the Java application deployed as proxy bridge?

In the Security Roles do you find the Predefined Role EcmDeveloper and did you grant this role to the user accessing the proxy bridge? This should be only relevant if you left BASIC authentication in the snippet code of web.xml.

Be sure prior the deployment that within the Proxy Bridge you inserted the correct Repository ID and Key generated during the creation of your repository in the Document Repositories tab of the Cockpit, as you won't be able to check this values from SAP Cloud Platform cockpit.

Regards,

Matteo

0 Kudos

Hi Matteo,

Yes, I am using the url that we get after deployment of the Proxy Bridge.

Also, we have security role EcmDeveloper in place and given the necessary access. And we have maintained the web.xml code as mentioned below.

And the Repository Id and key maintained accordingly. Please let me know if we have missed something.

<web-app>

<display-name>cmisproxy</display-name>

<servlet>

<servlet-name>simpleServlet</servlet-name>

<servlet-class>com.sap.ecm.proxy.SimpleServlet</servlet-class>

<load-on-startup>1</load-on-startup>

</servlet>

<servlet-mapping>

<servlet-name>simpleServlet</servlet-name>

<url-pattern>/hello</url-pattern>

</servlet-mapping>

<servlet>

<servlet-name>cmisproxy</servlet-name>

<servlet-class>com.sap.ecm.proxy.CMISProxyServlet</servlet-class>

</servlet>

<servlet-mapping>

<servlet-name>cmisproxy</servlet-name>

<url-pattern>/cmis/*</url-pattern>

</servlet-mapping>

<security-constraint>

<web-resource-collection>

<web-resource-name>Proxy</web-resource-name>

<url-pattern>/cmis/*</url-pattern>

</web-resource-collection>

<auth-constraint>

<role-name>EcmDeveloper</role-name>

</auth-constraint>

</security-constraint>

<login-config>

<auth-method>BASIC</auth-method>

</login-config>

</web-app>

thanks,

Chakravarti

mconvertino
Explorer
0 Kudos

Hi Chakravarti,

Actually I can see some differences from the Sample Code that look weird, why are you defining more than one servlet? You should adjust only the CMISProxyServlet with your repository name and key to let the proxy works.

Regards,

Matteo