cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to Startup Web AS service automatically

Former Member
0 Kudos

Hi,

Two weeks ago I updated my Web AS 6.40 to SP13. From that point if the machine needs to be rebooted, the service will not startup automatically. Before the update it startup properly. Now I have to do it manually even with service set to Starup Automatic. Is there a setting that I missed to set during the update? Thanks in advance.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Jose,

if I got your question right - you want your Web AS start automatically when your machine starts. If this is the case, you can configure this behavior by modifying the Autostart property in the start profiles of your Web AS. To start the server automatically, you must set the property to 1. You also need to do that in both the start profile of your central services (START_SCS<id>_<host>) & Java central instance (START_JC<id>_<host>). Those files are located in the \usr\sap\<SID>\SYS\profile directory.

Hope that helps!

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi,

If you have still problem try the following:

If it is windows( PLEASE BE CAREFUL WHILE DOING the following)CLOSE MMC, WINDOWS SERVICES WINDOW BEFORE DOING.

1) go to \usr\sap\<SID>\exe\run\

2) doubleclick sapstartsrv.exe

3) A window will be openend with the various options

4) select 2 radio button to uninstall the service.

5) now select 1 radio button to install the service.

6) give SID, SYSNO, STartup pfofile(\usr\sap\<sid>\profile\Start*

7) give username as .\SAPService<sid> and enter the password

😎 and click ok.

REGARDS

Anand.M

Former Member
0 Kudos

Hi Jose,

You can change each service startup mode from config tool as manual or automatic.

So, goto configtool at location <drive>:\usr\sap\<sys ID>\JC<instance number>\j2ee\configtool\configtool.bat

and change the startup property. It requires restart of Server.

Regards,

Bhavik