cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to logoff from BI Launchpad after making customizations to it.

Former Member
0 Kudos

Hello,

We are using BO BI 4.1 SP3 on windows 2012 server.

The requirement is to display a message on BI Launchpad Login Page. I made the required changes by adding message in Custom.jsp file (copy of logon.jsp). Cleared the cache from tomcat and started Tomcat.

I can see the changes on login page but when I Log out the changes disappear.

To resolve it I followed below steps:

1. Stop Tomcat

2. Copy the file BIlaunchpad.properties from <Tomcat Installation Dir>\webapps\BOE\WEB-INF\config\default to <Tomcat Installation Dir>\webapps\BOE\WEB-INF\config\custom

3. Configure the exit URL in the new properties file. There is a parameter url.exit in the properties file. Configure it as url.exit=http://server:port/BOE/BI

4. Start Tomcat

Now, When I try to log off the screen hangs up and show a blank white screen and doesn't get log off. I cleared the cache but no luck. I went through many post to search for the solution but could not find any. There is some error which is restricting it. The error message is as below.

Please advise.

Thanks,

Akhil

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Folks,

I solved this issue at our site by deleting the Tomcat cache, i.e.,

1. log into the server hosting Tomcat.with an administrator account.

2. Stop Tomcat.

3. Open explorer and navigate to the installed tomcat folder,

   e.g., INSTALL_PATH\tomcat\work\Catalina\localhost\BOE

4. Delete all the folders and files in this BOE folder ONLY.

5. Start Tomcat.

6. Tomcat will take a few minutes to re-create all these folders and files before it will process new connections

7. Problem gone.

Well it worked at our site !

Hope this helps.

RF

Former Member
0 Kudos

Do you have any page or site redirection set up, either in Apache, Tomcat, or custom.jsp, or a reverse proxy configured?

Former Member
0 Kudos

Hello Brian,

In BIlaunchpad.properties file under D:\Program Files (x86)\SAP BusinessObjects\tomcat\webapps\BOE\WEB-INF\config\custom, I have the url.exit setup as http://server:port/BOE/BI/custom.jsp.

I have not setup any other redirection page except what I mentioned above.

Thanks,

Akhil

Former Member
0 Kudos

Hello Guys,

I got it fixed finally.

I took reference of 2 SAP notes - 1872608 & 2068867.

Steps to fix the issue:

  1. Stop tomcat
  2. Create a blank logoff.jsp file and edit it in the text editor
  3. Include the following script in the file

<HTML>

<HEAD>

<script>

top.location.href = document.location.href;

window.top.location.href = "http://server:port/BOE/BI";

</script>

</HEAD>

</HTML>

   4. Save the file and copy it over to the TOMCAT_HOME/webapps/ROOT/

   5. Edit the BILaunchpad.properties from "C:\Program Files (x86)\SAP BusinessObjects\tomcat\webapps\BOE\WEB-INF\config\custom" folder.

  6.  Set the following in url.exit parameter: url.exit=/logoff.jsp

  7. Save the file

  8. Delete ..//tomcat/work/Catalina/localhost/BOE

  9. Start Tomcat



Hope it helps for someone else too.


Thanks,

Akhil

Former Member
0 Kudos

What happens if you undo the url.exit customization (leave it blank)? Or, redirect back to the custom.jsp logon page explicitly, e.g. http://server:port/BOE/BI/custom.jsp (or whatever the actual path is)?

Former Member
0 Kudos

Hello Brian,

I tried leaving url.exit blank and also tried giving the value as http://server:port/BOE/BI/custom.jsp but after logging off it's giving same error "Invalid argument" as I mentioned in my first post.

Please advise.

Thanks,

Akhil

Former Member
0 Kudos

Akhil

Have you tried increasing the maxhttpheadersize?

Refer - http://scn.sap.com/thread/3259352

~VJ

Former Member
0 Kudos

Hello VJ,

Thanks for your suggestion!

I increased the maxhttpheadersize and restarted tomcat but still the same above error remains.

Any other idea...

Thanks,

Akhil