cancel
Showing results for 
Search instead for 
Did you mean: 

unable to launch integration builder

Former Member
0 Kudos
196

Hi,

While I am launching Integration Builder, getting an error that "Java.lang.NullPointerException".

I made modifications that are suggested in the weblogs here, but still getting the same error.

Please tell me the solution....

Thanks,

Ravindra.

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi !!!

I used to have the same error after I finished installing XI SR1, but I noticed that I missed an step from the installation which was to the "Client 000 Copy", XI must run on its on client.

The other reason to cause this problem might be that you didn´t maintain correctly the "HTTP Destinations", check the step "Creating HTTP Destination pmistore in the Java Environment", or steps related to this on the SR1 installation guide.

Any way, I recommend you to start all over again reading really carefully each step of the manual, cause I solve the problem you have by doing that.

Former Member
0 Kudos

Hi,

Thank you for your answers.

I checked the suggestions that are given by you but no luck.....

I am using jre1.4.2_08, but I am using SP6, is it creating the problem?

I want to patch it to SP11 or greater. Whats the latest patch available and from where I can download it??

Thanks,

Ravindra.

Former Member
0 Kudos

you can download the patches by going to SAP Marketplace, but you need to have an user id and password. Ask your security team to provide one.

Follow the path

http://service.sap.com/download

<b>Download --> Support Packages and Patches --> Entry by Application Group --> SAP NetWeaver --> SAP NETWEAVER --> SAP NETWEAVER 04 --> Support Package Stacks --> Support Package Stacks</b> Deselect all except <b>Process Integration (XI)</b>

There you can download them.

First you need to patch ABAP Stack, then Kernel, next Java Stack and finally XI.

Remember that Patching ABAP stack is sequence means your ABAP and BASIS components have to be applied until the desired patch level, where as J2EE & XI patches can be applied directly from any patch level to the upper level. You do not need to download all of them in sequence. Just download the desired the level and apply them after the ABAP stack patches.

regards

SKM

bhaskar_ghandikota
Participant
0 Kudos

Ravindra,

Check that You have j2sdk1208 and its jre.

Check that You have two versions of jre (Srinivas Vankamamidia also suggested the same)

Set the java home and pathe in environmental variables.

Then this should be enough to launch Java webstart and IB.

To get the Service packs, log into service.sap.com/sp-stacks. Here youc an choose SP12 or SP13 as per your needs and the install docs also.

Also there is a weblog from Sudhir Porumamilla that tells some steps to get IB up.

Hope this helps.

Thanks,

Bhaskar

Former Member
0 Kudos

Hello,

JRE 1.4.2-02/04/06/08 should be good. Make sure you have one JAVA JRE version just in case to avoid the conflicts.

JAVAEBSTART-FILE-PREFERENCES and check the port should be set to NONE. Clear the cache from Advanced tab as well.

Also, try to delete the FILES/COOKIES from Internet explorer-tools-options.....

Hopefully this should resolve.

Former Member
0 Kudos

Hi Ravindra,

Check you are having right version for JRE.I think

it gives problem with JRE 5.

I think it should be j2re1.4.2_08.

Hope it Helps.

Thanx.

Rekha.