Showing results for 
Search instead for 
Did you mean: 

Unable to find associated SLD element... (SAP_XIIntegrationDirectory)

Former Member
0 Kudos

Hi All,

We have installed PI 7.1 SP 7 on windows platform. All Post Installation activities were completed succesfully. I am able to succesfully execute transactions: SLDCHECK, SXMB_ADM (check) etc.

All RFC connections are also configured properly. SXI_CACHE working fine.

But when I tried to create a communication channel it gives me following warning message:

" Unable to find associated SLD element for specified class (source element: SAP_XIIntegrationDirectory ".

Following are my analysis:

1. CPA cache refresh is failing ..

error: <?xml version="1.0" encoding="UTF-8" ?>

- <CacheRefresh>

<Info>CPA cache refresh (mode=full) executed in 1485 milliseconds.</Info>

- <Confirmation>

- <CacheRefreshError>




- <GlobalError>

<Message>Couldn't parse Configuration Data cache update XML string from Directory.</Message>

2. In SLD-> Technical Systems -> Technical system type = Process Integration

I am only able to find 5 entries instead of 6. Entry for Integration Directory on <sid:server> is missing.

But application systems are visible against all entries as suggested in blog:


Please can you suggest whether the note 764176 is applicable for us. I need to confirm this as it suggests deletion of certain components of SLD and then creating them manually.



Siddhesh S.Tawate

Accepted Solutions (1)

Accepted Solutions (1)

Product and Topic Expert
Product and Topic Expert
0 Kudos

Hello Siddhesh

Yes, note #764176 is relevant and should be applied. Before you do that, apply note #1117249 Incomplete Registration of PI components in SLD.

Hopefully this will resolve the error.



Former Member
0 Kudos

Hi Smith,

Sorry forgot to update thread, but note 1117249 alone worked.




0 Kudos

In case the note doesn't work try the following:

Logon to the NWA and goto Operations Management --> Start&Stop.

Select Java EE Applications and restart all instances of

Former Member
0 Kudos

1117249 also solved the problem for me.



0 Kudos


I have same issue. You just remove from list the one does not have domain and restart this services?

  • (Integration Builder/Configuration)
  • (Adapter Engine)
  • (Runtime Workbench)
  • (Integration Builder/Design)


Former Member
0 Kudos

Hi Jorge,

I have tried note 1117249 and also 764176 . But still show problem like

Unable to determine the name of the central Adapter Engine from the System Landscape Directory at this time Notifications to the central Adapter Engine are therefore listed using the technical name of the Adapter Engine This is usually structured as follows: af.<SAP System ID>.<Name of application server>

1 day before it's working properly but now i ma facing problem. I have restarted server many time.

Answers (0)