cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to fetch site...error 401

Former Member
0 Kudos

Hi All,

I have installed the Portal succesfully and can access it through the internet.

But when it implement a simple URL iview to another web-side it gives me a "401 - not auth" error...

Where should I look in the Portal server to check that its restrictions/permisssions are correcly set up??

Thanks in advance!

Lars

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

The problem comes when I press "Browse" or "Capture" on the URL iview editor - I am running Nw04 SP15 (sneak preview version)

Former Member
0 Kudos

The Browse & Capture functions use the proxy settings in the portal (under Service Config > com.sap.portal.ivs.httpservice) so you need to set these if you have to go through a proxy to get to the internet:

http://help.sap.com/saphelp_nw04/helpdata/en/f5/eb51730e6a11d7b84900047582c9f7/frameset.htm - 3rd paragraph

Regards

Jane

Former Member
0 Kudos

Hi Jane,

I dont use proxy - but I can't find the "under Service Config > com.sap.portal.ivs.httpservice" in the portal? Where should I look??

Thanks a lot for your time so far - no matter what you will earn some points - be sure of that!

Former Member
0 Kudos

Hi Lars,

It's under System Administration > System Configuration > Service Configuration. Then, in the folders, go to Applications > com.sap.portal.ivs.httpservice > Services and open the Proxy service. Here you can enter a HTTP & HTTPS proxy, including addresses to bypass proxy. More info at http://help.sap.com/saphelp_nw04/helpdata/en/33/8abf9e0ce011d7b84900047582c9f7/frameset.htm

No problems - thanks!

Jane

Answers (4)

Answers (4)

Former Member
0 Kudos

Hi Jane,

You where right - it was the proxy - but I needed to restart the J2E /Portal to make it work - there is your points!

Former Member
0 Kudos

Hi Jane,

I have cleared all the settings in the proxy (since I don´t have proxy - ok?) - but It still dos´nt work...

I have given you some points anyway...

Former Member
0 Kudos

Hmm odd. Error 401 is not authorized to view content but if you can preview ok then I don't know

Hope you find the problem. Thanks for the points!

Jane

Former Member
0 Kudos

Hi Jane

Its "Client side" and yes I can surrely see the the content for the URL of: "http://www.dmi.dk/dmi/index/" in a normal browser...

What in the h.. can be wrong??

Former Member
0 Kudos

Can you preview the iview ok? When you get the error, is it embedded in the portal page or open in new window? Could there be a problem with it being in an iframe?

Jane

Former Member
0 Kudos

Hi Lars,

Which Fetch Mode does the iview use (see iview properties), Client-Side or Server-Side?

If client-side, check that you can access the URL of the web-site outside of the portal. If not, you won't be able to access from inside the portal either.

If server-side, check you have defined the proxy settings for the portal correctly

http://help.sap.com/saphelp_nw04/helpdata/en/8d/8e0c7e477e4239a7ee288d7846a0bb/frameset.htm might help.

Regards

Jane