Showing results for 
Search instead for 
Did you mean: 

Unable to Export to anything except pdf.

Former Member
0 Kudos

I can't get my exports to work in any format except pdf.

For example if I run:

ByteArrayInputStream byteIS = (ByteArrayInputStream)reportClientDocument.getPrintOutputController().export(ReportExportFormat.MSExcel );

I get several long exception messages.

I get:

Failed to load the resource 'UnknownExportFormat' from the bundle java.util.PropertyResourceBundle@1bf98eb.

java.util.MissingResourceException: Can't find resource for bundle java.util.PropertyResourceBundle, key UnknownExportFormat


Followed by: UnknownExportFormat---- Error code:-2147467259 Error code name:failed ...

Followed by:

Caused by: com.crystaldecisions.reports.exportinterface2.exceptions.UnknownExportFormatException: UnknownExportFormat

Obviously Crystal gives what appear to be intentionally unhelpful exceptions, so I don't know if that does anything for anyone. Could the problem be missing jars or does anyone have any other ideas?

I thank you in advance,


Accepted Solutions (1)

Accepted Solutions (1)

Active Contributor
0 Kudos

What version and service pack are you using?

MSExel support came with CR4E 2.0 Update 1 - so I would get the latest build.


Ted Ueda

Former Member
0 Kudos

Yes. This solved the problem. Apparently the earlier version gives you an Excel option, except it doesn't work. There is also an Excel Record one which works, but doesn't allow formatting.

Active Contributor
0 Kudos

The API is common with the Report Application Server server-client SDK, so some export options not yet supported with the CR4E engine is listed.

Supported exports for Crystal Reports for Eclipse, except MS Excel which was new with a Service Pack, are listed in the Developer Guide.

That the export format is listed in the enumeration and documented unfortuately does cause misunderstandings.



Ted Ueda

Former Member
0 Kudos

Will export to txt files be supported in later updates for CR plugin for Eclipse?

Former Member
0 Kudos

I am usgin latest jars and i could create report in the following formats

u2022 _crystalReports

u2022 _MSWord

u2022 _MSExcel

u2022 _RTF

u2022 _editableRTF

but when i try to create in any of these hereunder

u2022 _text

u2022 _characterSeparatedValues

u2022 _tabSeparatedText

u2022 _XML

i am getting the following error

[2010-05-26 10:36:25,534,,ERROR,com.crystaldecisions.reports.common] Failed to load the resource 'UnknownExportFormat' from the bundle java.util.PropertyResourceBundle@39826.

java.util.MissingResourceException: Can't find resource for bundle java.util.PropertyResourceBundle, key UnknownExportFormat

at java.util.ResourceBundle.getObject(

at java.util.ResourceBundle.getString(

at com.crystaldecisions.reports.common.CrystalResources.loadString(Unknown Source)

at com.crystaldecisions.reports.common.CrystalResources.loadMessage(Unknown Source)

at com.crystaldecisions.reports.common.CrystalResourcesFactory.getLocalizedMessage(Unknown Source)

at com.crystaldecisions.reports.common.CrystalException.getLocalizedMessage(Unknown Source)

at Source)

at com.businessobjects.reports.sdk.JRCCommunicationAdapter.if(Unknown Source)

at com.businessobjects.reports.sdk.JRCCommunicationAdapter.a(Unknown Source)

at com.businessobjects.reports.sdk.JRCCommunicationAdapter$2.a(Unknown Source)

at com.businessobjects.reports.sdk.JRCCommunicationAdapter$ Source)

at com.crystaldecisions.reports.common.ThreadGuard.syncExecute(Unknown Source)

at com.businessobjects.reports.sdk.JRCCommunicationAdapter.for(Unknown Source)

at Source)

at com.businessobjects.reports.sdk.JRCCommunicationAdapter.request(Unknown Source)

at com.businessobjects.sdk.erom.jrc.a.a(Unknown Source)

at com.businessobjects.sdk.erom.jrc.a.execute(Unknown Source)


Could anybody please advise me this is not supported or if i am missing something.

Thanks in advance

Answers (0)