cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to deploy fiori app with custom namespace package(other than $tmp)

Former Member
0 Kudos
388

Hi,

I am getting the below error when I try to deploy the fiori application in different packages (i.e. other than $tmp) package.

Please help me to resolve the issue.

Regards,

Harish

Accepted Solutions (1)

Accepted Solutions (1)

michal_keidar
Active Contributor
0 Kudos

Hi,

Please attach the failing request and its response from the network trace taken from your browser's developer tools (F12).

Also please attach the xml downloaded when you reach: <your host>:<your port>/sap/bc/adt/discovery

Thanks,
Michal.

Former Member
0 Kudos

Hi,

I have attached the discovery.xml file which I got from the given URL.

Please find the attachment.

Thanks,

Harish

michal_keidar
Active Contributor
0 Kudos

Thanks, your discovery seems ok, what about the failing request and response from the network trace? We need to see what the backend has returned

Former Member
0 Kudos

Hi Michal,

Sorry for the late reply, When I saw the network headers while selecting the package I am getting 404 error for discovery.xml. Please find the below screen.

Thanks,

Harish

michal_keidar
Active Contributor
0 Kudos

Ok, please attach how you configured your destination

Former Member
0 Kudos

Hi Michal,

The issue is with the destination URL configuration I debug it in the dev tools and now it is working fine.

Thanks,

Harish

Answers (2)

Answers (2)

souvikroy
Participant
0 Kudos

Harish ,

This might be authorization issue in the gateway server . Log in to the SAP gateway server . Then , get the error one more time from Web IDE and then check the SU53 Transaction in the gateway server and see if there is any authorization failure .

Former Member
0 Kudos

Hi Souvik Roy,

I tried the solution provided by you, All authorizations checks looks fine I am getting the below output in SU53 when I reach the transaction after selecting the package from the web IDE.

Thanks,

Harish

saurabh_vakil
Active Contributor
0 Kudos

Are you sure that the package you are mentioning in the Package field actually exists in the front end system?

Former Member
0 Kudos

yes the package is created and it is showing in the list while selecting.