Showing results for 
Search instead for 
Did you mean: 

Unable to create Database module as per the sap Teched 2018 DAT374 session

0 Kudos

Hi experts,

Im trying to replicate the DAT374 session in webide.

where im not able to build the db module as it says service instance "TechEd2018CentralDB.teched-2018-cc" does not exist and failed to build the database module.

so i created a new service instance and provided that in the mta.yaml file for the centralDB with type "org.cloudfoundry.user-provided-service" and parametes {service-name - newly created service instance}.

now i got a different error and again failed to build the database module.


error log :-

12:36:04 PM (Builder) Build of "/dat374/db" started. 12:36:16 PM (DIBuild) Build of "/dat374/db" in progress. 12:36:19 PM (DIBuild) Service provisioning for module: '/db'
Creating a service instance for the 'CentralDB' resource type is currently not supported.
Service instance 'dat374-hdidb-P1942725372-workspaceuOKUB3hML8WY9zpk' for resource 'dat374-hdidb-P1942725372-workspaceuOKUB3hML8WY9zpk' already exists, no operation will be performed.
[INFO] Injecting source code into builder...
[INFO] Source code injection finished
[INFO] ------------------------------------------------------------------------
Your module contains a package.json file, it will be used for the build.

12:36:24 PM (DIBuild) added 37 packages from 79 contributors in 1.348s

> deploy@ start /home/vcap/app/.java-buildpack/tomcat/temp/builder/hdi-builder/builds/build-7285260780734966006/db
> node node_modules/@sap/hdi-deploy/deploy.js

@sap/hdi-deploy, version 3.7.0 (mode default), server version (, node version 8.9.1
Using service replacements from environment variable "SERVICE_REPLACEMENTS" with 1 replacements
No ignore file at /home/vcap/app/.java-buildpack/tomcat/temp/builder/hdi-builder/builds/build-7285260780734966006/db/.hdiignore.
Collecting files...
Collecting files... ok (0s 2ms)
3 directories collected
5 files collected
0 reusable modules collected
Target service: dat374-hdidb-P1942725372-workspaceuOKUB3hML8WY9zpk
Processing grants files...
Processing "cfg/central.hdbgrants"...
Using service "central-db-service" of type "hdi"
Granting schema roles in the container "D3B756F995E24352B168DAF16CAB485C" and the parameters "[]"...
Granting the schema role "admin" to the principal "DAT374_3#OO" in the schema "" with grant option = "0"
Error: Granting schema roles in the container "D3B756F995E24352B168DAF16CAB485C" and the parameters "[]"... failed [8214221]
Error: Database error 389: : invalid role name: admin: line 1 col 7 (at pos 6) [8201003]
(nested message: HDI call failed)
grantor service: "central-db-service", type: "hdi", user: "SBSS_61800447415722129476806434534579288070551592183866235085443790172" (hdi_user)
file name: /home/vcap/app/.java-buildpack/tomcat/temp/builder/hdi-builder/builds/build-7285260780734966006/db/cfg/central.hdbgrants
(0s 253ms)

npm ERR! errno 1
npm ERR! deploy@ start: `node node_modules/@sap/hdi-deploy/deploy.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the deploy@ start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/vcap/app/META-INF/cache/8.9.1/.npm/_logs/2019-01-08T07_06_25_542Z-debug.log
12:36:24 PM (Builder) Build of /dat374/db failed.


what might be the possible error and how it can be solved..

thanks and regards


View Entire Topic
Developer Advocate
Developer Advocate
0 Kudos

The content of the other delivery unit, TechEd2018CentralDB, is necessary for this exercise. You can't just create a User Provided Service with the same name and expect it to work. You either need to build and install TechEd2018CentralDB on your system or simply skip this one exercise that does cross-container content. If you want to install TechEd2018CentralDB, the project can be found here:

0 Kudos

it did worked,

thanks for the info Thomas.

thanks and regards ,

Pavana Rahul.