Showing results for 
Search instead for 
Did you mean: 

Unable to connect to ASE 16 with python 3.8 on RHEL8



I've a ASE 16 installed on RHEL 8 with python3.8 and I'm unable to connect to the server with python.

If I do not specify the password with the default, I have a Login Failed (normal behaviour) :


Cannot raise error, context is NULL

Traceback (most recent call last):

File "", line 55, in <module>

conn = sybpydb.connect(user='sa', password='')

sybpydb.ProgrammingError: ('Login failed.\n', 4002)

If I put the good password , it seems that the connection is done but I have the following error message :


Traceback (most recent call last):

File "", line 55, in <module>

conn = sybpydb.connect(dsn="user=sa;password=XXXXXXX")

sybpydb.ProgrammingError: ('ct_con_props(): user api layer: external error: An illegal value of 9234 given for parameter property.', 5)

MyASE version is Adaptive Server Enterprise/16.0 SP03 PL10/EBF 29808 SMP/P/x86_64/SLES 11.1/ase160sp03pl10x/3880/64-bit/FBO/Wed May 12 20:32:12 2021

I tried to use all installed on my server, the latest I have is in $SYBASE /OCS-16_0/python/python34_64r/lib

My PYTHONPATH is (I also tried with other python3x_64r versions)

setenv PYTHONPATH ${SYBASE}/${SYBASE_OCS}/python/python37_64r/lib:${SYBASE}/${SYBASE_OCS}/lib

My PYthon version is :

Python 3.8.8 (default, Aug 11 2021, 06:52:42)

[GCC 8.5.0 20210514 (Red Hat 8.5.0-3)] on linux

Python 3.8 is not supported ? I should install python 3.7 instead ?thank you for your helpRegardsHervé

Developer Advocate
Developer Advocate

Hi Bauchon. I added the ASE tag to make your question visible in the relevant community. Regards. -Witalij

View Entire Topic
0 Kudos

Currently Python 3.8 is not supported.

Current version of python we have built modules for:
~/ase1641$ cd OCS-16_0/python

~/ase1641/OCS-16_0/python$ ls

python26_64r python26ucs4_64r python31_64r python34_64r python37_64r

python26_64r = Python 2.6

python26ucs4_64r = Python 2.6

python31_64r = Python 3.1

python34_64r = Python 3.4

python37_64r = Python 3.7

We are currently trying to release a new python module for newer versions of python.

0 Kudos

Hey, @ryan_hansen, can you please confirm that do other python version like 3.9 and above are supported or not?