cancel
Showing results for 
Search instead for 
Did you mean: 

Trying to install unixodbc for Smart Data Access

Former Member
0 Kudos
129

I am currently running HANA One on AWS SPS9.  I need to use smart data access and have determined that I need to install unixodbc (based on the SAP HANA Administration Guide).  It tells me to download the package, which I did, but then wants me to run


./configure

This seems to want to do a compile, but there is no compiler in the path.  I have tried this from ec2-user as well as root.  when I do a

find . -name gcc -print

from the root directory, there are no results (other than a library). When I try to use yast or zypper, I get no where.

hanaserver:~ # zypper install gcc

Refreshing service 'susecloud'.

Loading repository data...

Reading installed packages...

'gcc' not found in package names. Trying capabilities.

No provider of 'gcc' found.

Resolving package dependencies...

Nothing to do.

When I try yast, I see no software to install related to gcc or similar.

Yet there is no gcc, cc, gcc46, or anything like this in the system.  What do I need to do to proceed?

Thanks

Bob

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

I just created a simple SUSE 11 EC2 instance and logged into it.  When I ran YAST then selected Software -> Software Management  and searched for gcc, I got a good sized listing, including gcc.  But when I do it in my HANA instance console, only get the following:

libgcc43 xC compiler runtime libraryx            x4.6.9  x

libgcc_s1xC compiler runtime libraryx            x4.7.2_2x

Is there a way to fix this?

Thank you

Bob