cancel
Showing results for 
Search instead for 
Did you mean: 

Transport to Consolidation system doesn't work

Former Member
0 Kudos
169

First of all, sorry if this is a silly question but I have to admin I am a little missed with NWDI. Every step we did we have a new error

In this case, we have trying to move a iView using NWDI and process to transport from

Development Environment to Consolidation doesn't work.

We have done all steps to deploy changes in Development and iview

has been updated correctly. But then, when we release the DC in NWDS

and go to Transport View - Consolidation tab and we do the import

althougth we have a successfully message with "Import Finished", the

iview has not been updated in Consolidation system .

We have doublechecked server, port and SDM password in Runtine System

tab for this server and everything is OK.

I have analyzed all logs generated during Import process in Transport

Studio and no error is showed.

I have find in CBS Consolidation builspace and we don't have any activities pending, and additionally the DC doesn't appear in this buildspace. However in Development buildspace it is.

Could somebody help us putting some ligth on it? Where can I to try to obtain log information about why this change is not moved to Consolidation?

Thanks in advance.

Accepted Solutions (0)

Answers (5)

Answers (5)

Former Member
0 Kudos

Just wondering, has anybody been able to resolve this???

We're facing a similiar issue and I can see the .dcdef file in cons and dev workspaces (DTR) but unable to see the changes in the Cons system.

Please update.

cheers,

kev

Link to the thread I've posted:

Former Member
0 Kudos

Hi Javier,

I have sometimes a similar problem: we are developing WebDynpro applications. The activities are checked in and transported correctly, but on the destination system only the old release shows up.

My solution of this situation is not elegant, but effective (steamroller tactics or in german "Holzhammermethode"):

- Log on to the console of the machine where your destination system for your deployment is running. Start up the (really slow) standalone SDM application and select the components, which are not updated correctly, for undeployment and undeploy them manually.

- After successful undeployment reimport the component/activity in the JDI transport studio again.

As mentioned before, not elegant, but effective. It worked for all the situations now, when the deployment did not work, but there was no obvious reason available.

Regards

Karsten

Former Member
0 Kudos

Hi Marc,

thanks for your reply. I think you are very close of the issue resolution becuase as you have suggested the .dcdef file is not in the CONS DTR workspace. We have only the code I changed in the last code version.

My question now is ... is there any way to recover this information?

Do I have to change something in the configuration or settings in order to can move code from DEV to CONS?

Thanks.

Former Member
0 Kudos

Hi Javier,

I'd check the workspaces to see if there is some integration into dev/active that is not present in cons (see e.g. http://help.sap.com/saphelp_nw70/helpdata/en/f9/b500b9f2d943bb8d63930d68076d25/frameset.htm ). Worst case you can integrate the activity manually using the DTR command line tool or the admin plugin from within NWDS.

Maybe using the history in the CMS transport studio can help if you go back to the original import and put it back into the import queue and then try to reimport. I haven't encountered a situation like yours before so I'm not sure if that is possible or it it will help though.

Regards,

Marc

Former Member
0 Kudos

Hi,

you released the activity that created the DC, imported that into the cons-system and the CBS buildspace afterwards does not show the DC? Take a look at one of the cons-workspaces in DTR to see if the .dcdef file of the DC exists there.

Background: Deployment will only be done after CBS has built the DC. If there is no DC in the CBS buildspace there's nothing to deploy. CBS will only recognize a DC if there is at least a .dcdef file containing the DC metadata. Thus I would check first check if the files exist in the right DTR workspace and maybe do a workspace comparison to check if the original activity was really integrated.

Regards,

Marc

Former Member
0 Kudos

May be you are deploying the same version . NWDI is a version control SAP System .look at the time stamp of the deployed sca/archive file