cancel
Showing results for 
Search instead for 
Did you mean: 

Transport prompt when creating BEx Workbook

Former Member
0 Kudos

We have been using BEx Analyzer for a long time on our BW system and users quite happily create Workbooks (using "Save Workbook As...."), and when thye do this they get no prompts for Transport Package/Number from any Bex Query.

However we have recently created a Bex query on the BW element of our APO system. Whilst the users can run the BEx Query in BEx Analyzer with no issues, when they come to save the workbook it is prompting for a Transport Package and then Transport Number every time they create a new Workbook.

 

I have checked in Transport Connection that the underlying query has a Transport Package, there is a default Transport number setup and open for the Transport Pakage used, and there is actually also a Standard Bex Transport open, however when saving a workbook from APO BW it prompts every time. The question is Why and how do I switch off this behaviour so BW and APO BW behave the same?

 

On our BW system it does not seem that there is a transport task setup in users name everytime they setup a Workbook. It feels to me that somewhere in our BW system somehow we have "swtiched off" Workbooks (and views I think) as transportable objects somehow?????? But that is just a guess. I don't know how to check this though.

Can anyone think of what may be happening here?

Regards

Simon

Accepted Solutions (1)

Accepted Solutions (1)

former_member182470
Active Contributor
0 Kudos

How to set your system Transport Request settings

Goto RSA1-->Transports Tab-->Follow below image

If you switch on standard, then every activity will ask you for transport request through a pop up instantly.

If youSwitch -off standard, then all your activities will get saved in to local objects. Finally you will have to collect from RSA1-->Transprt tab-->Object types

Check whether your system is open in SCC4 tcode.

Former Member
0 Kudos

Hi Suma

Thanks, this has worked. I had tried Object Changeability settings but because our system is open for changes these had no effect. I was not aware of the setting you showed, but they were indeed different between BW and APO. I have changed in APO and all seems to work as expected now, many thanks

Simon

former_member182470
Active Contributor
0 Kudos

Hi Simon,

Great to know that my reply resolves your issue.

Regards,

Suman

MGrob
Active Contributor
0 Kudos

Hi


FYI that change also has an impact on the rest of your APO developments. None of the objects that you create will cause a transport request anymore unless already transported before

Martin

former_member182470
Active Contributor
0 Kudos

Nothing to worry about your future developments. You can easily collect all your developments in RSA1-->Transports-->Object types. So you need not to worry about after the setting which i have proposed.

Actually we should not open the client SCC4 unless it is quite emergency.

Answers (2)

Answers (2)

MGrob
Active Contributor
0 Kudos

Hi

If you aren't using the standard transport way and the issue is the same check tx SCC4

Martin

RamanKorrapati
Active Contributor
0 Kudos

Hi,

Do the settings as stated by suman at your environment.If your not authorized then take basis team help to set the above settings then it will pop up transport request for every action.

Thanks