Showing results for 
Search instead for 
Did you mean: 

Translating with Umlaut / mutated vowel

Former Member
0 Kudos

Hi everybody,

I got the next problem in WD4J.

I've created a simple text view on my screen with the content "headline". After saving the view I have the possibility to translate the text in the navigator. The only thing I have to do is to copy the xlf file of the view and then I can edit the element in the tab resource text. This is very simple and works perfectly.

Until I don't try to translate a text that will contain in german a mutated vowel like ä ü ö. I can edit my entry but when I save the xlf nwds is processing a roll back to the old version without the mutated vowel. When I am not using an umlaut the xlf file will be saved and works perfectly.

How can I translate content with special chars like ä ü ö in the xlf file?

Thx a lot.

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos


Use "UTF -8" encoding for text editor in NWDS.

In Window>Preferences>Workbecnh>editors select UTF-8.Close NWDS and open again.



Former Member
0 Kudos

Hi Radhika,

I found your point under

Window > Preferences > General > Editors > Text editors > Spelling

but there the value "UTF-8" is already selected on the point encoding.

I can enter the mutated vowels in the text fields and edit the next one. That works. But when I press the save Icon it involves a roll back to the old values.

I have added a screenshot.


As you can see, the editor will accept my changes but on pressing save all changes will be reset.

Thx for help

Edit: Maybe this helps to find a solution: on the tab "header" the field "source language" is disabled and contains the creation language of the component.

Edited by: Dirk Schilling on May 7, 2010 3:56 PM

Former Member
0 Kudos

Hi at all,

today I tried the same procedure in a new virtual machine with NWDS 7.0 instead of NWDS 7.1. I've created a web dynpro component and all necessary content. Then I opened the xlf file of the main view and the field "source language" was not disabled, so I can change the language to the one I want.

But why I couldn't change the language in NWDS 7.1? Why is the field "source language" of the xlf-file disabled?

This is very strange because I couldn't believe that a newer version of NWDS has less functions.

Thx for any help or advice

Former Member
0 Kudos

Solved problem by myselt. Can I give 10 points to me?

Just kidding!

The resolution:

Open the file from NWDS with the normal text editor. Now you see the pure XML Coding of the file and you can hardcode the source language.