cancel
Showing results for 
Search instead for 
Did you mean: 

Tranformation activation throws short dump

Former Member
0 Kudos

Hi all,

I am on SP9 earlier when assinging formulas in transformations i used to get "ASSERTION_FAILED" error. I searched for oss note and installed the following notes (along with there prequisites) in the below order

971020

1008381

1011638.

<b>Now on activation i get a syntax error.</b>

Runtime Errors SYNTAX_ERROR

Date and Time 01/09/2007 13:47:19

<b>Short text</b>

Syntax error in program "CL_RSTRAN_GEN=================CP ".

<b> What happened?</b>

Error in the ABAP Application Program

The current ABAP program "CL_RSTRAN_TRFN================CP" had to be terminated because it has come across a statement that unfortunately cannot be executed.

The following syntax error occurred in program

"CL_RSTRAN_GEN=================CP " in include

"CL_RSTRAN_GEN=================CM00T " in

line 54:

"Field "I_NO_FREE" is unknown. It is neither in one of the specified ta"

"bles nor defined by a "DATA" statement. "DATA" statement. "DATA" state"

"ment."

" "

The include has been created and last changed by:

Created by: "BSHKSC "

Last changed by: "SAP "

Accepted Solutions (0)

Answers (5)

Answers (5)

Former Member
0 Kudos

We had SP11 and transformation rules having formulas could not be edited and after editing we could not be managing to activate. I have applied Note "1036566 Various problems with formulas (see symptom)". It perfectly solved my problems check it out..

Former Member
0 Kudos

Note implemented

Former Member
0 Kudos

Hi everyone,

I am on SP11 and have had no problems activating the transformation with formulas and routines. I was able to load my data in dev and the results from the routines were correct. HOWEVER, I have another problem in that my active transformations are not in the metadata so when I try to transport, it doesn't find them. Help!

Thanks

Suzanne

Former Member
0 Kudos

Hi manga,

The Error occurs is GET_META_DATA_ROUTINE method in in program "CL_RSTRAN_GEN=================CP.

I have installed the notes but still have the same error.

Former Member
0 Kudos

Hi Manga,

954667, 981194 - are already in SP9

1008381 - resulted in the above error.

I have checked the program in se38 , This is code causing the error.


IF i_no_free IS NOT INITIAL.
    cl_rstran_gen_rule=>free( ).
    cl_rstran_gen_step=>free( ).
  ELSE.
    lr_model_rule = lr_model_step->get_rule_ref( ).
    cl_rstran_gen_rule=>free_single( lr_model_rule ).
  ENDIF.

The i_no_free element has not been declared anywhere in program.

Former Member
0 Kudos

I have an outstanding High priority message outstanding with SAP and will let you know as soon as we get this resolved.

Ian

Former Member
0 Kudos

Hello Ian,

I am having the exact same issues and have an open message with SAP as well. We have implemented a slew of notes but to no avail. Would love to compare notes on this. If you hear from SAP, could you please contact me? I will respond to the post if I hear from SAP and havent seen an update to this message or have heard from you...

Thank you, Craig Handjian

chandjian@sylack.com

Former Member
0 Kudos

Hi Craig,

Have created an OSS message to, will keep you posted on any update.Did you the same syntax error ?

Former Member
0 Kudos

We are in a similar situation. We are in SP10, but still same error while activating transformation. If we perform direct assignments its getting activated sucessfully. When we try to use other options like constants, routines, initial value etc for mappings it throws ASSERTION_FAILED error.

Lets see what SAP recommends.

Former Member
0 Kudos

Hi Syed,

I had same problem as you did, direct assignment worked but formula/routine threw up ASSERTION_FAILED.

To fix this i installed the oss notes mention in above post, those notes resulted in installation of lot of other notes as prequisites.Now i get the synax error when activating.

Former Member
0 Kudos

Hi Everyone,

We are on support package 9. I had the same assertion failed issues during imports. There were three key notes I wanted to implement, 1008381, 1011638, and 980549. These triggered the need for the rest to be implemented as well. Despite all those notes, we still have the short dump for the the syntax error with "I_NO_FREE" for CL_RSTRAN_GEN. I think there may be one or two other side effects as well since we are seeing other short dumps as well.

Thanks everyone. Craig

=========NOTES IMPLEMENTED===========

0000965972 Time-dependent master data - no data is read

0000976162 Currency trans/unit conversion: Target currency/unit initial

0000977225 Query on remote char terminates with ASSIGN_TYPE_CONFLICT

0000977926 Error BRAIN 070 occurs when filling a unit DataStore

0000979607 Runtime attribute: For example, source system is unavailable

0000980549 Endless D0/WHILE with inconsistent metadata

0000981806 RSUOM 065: No quantity conversion possible

0000983478 Request terminates with CX_SY_CONVERSION_ERROR

0000991119 RSM2 720 - Record (0) or segment (0001) unknown

0000995479 Breakpoints in der Simulation der Transformation

0001007327 RSTRAN 302 Exception .. aufgetreten DatenSatz geskipped

0001007765 Syntaxfehler bei Aktivierung einer Transformation

0001008381 Syntax error although the formula or routine is correct

and...

0001011638, 0000930495, 0000965507, 0000968517, 0000973258, 0000984890,

0000986199

Former Member
0 Kudos

Hi every one,

SAP suggested to implement note 981194, but note has status "<b>SAP Note 0000981194 cannot be implemented'"</b> as we are on SP9.Will update SAP and will keep you posted on any further changes.

Former Member
0 Kudos

Hi there,

SAP told me the same thing. If you read 981194, it states to implement if you are on SP 10. However, if you are SP 9, you need to consult note 986199. we have fully implemented this note and still we are getting the errors....

I to will post anything more I get from SAP on this. I have even referred SAP to this thread in case there are multiple folks looking into this issue at SAP.

Thanks, Craig

Former Member
0 Kudos

Hi Craig,

I installed note 986199 to, but still get an error So i rolled back the note.If iam not wrong i think i got the following error after implementing note 986199

The following syntax error was found in the program

CL_RSAR_FORMULAS==============CP :

"Formal parameter "I_RETURN_ORGINAL" does not exist. exist."

Former Member
0 Kudos

Hi there...

Working on a 2004S, SP9 system, and SAP just instructed us to deimplement and reimplement OSS note 1008381. We had originally imported version 7 of this note and I just put version 9 in. Seems to be working. There are a lot of interdependencies here on this, so there was a lot of code that was touched.

the one thing I am not totally certain of is, do we now need to rebuild all the transformations that we created prior to this new note going in...

Wanted to pass this along...

Former Member
0 Kudos

Check OSS notes 989932 ,998730