cancel
Showing results for 
Search instead for 
Did you mean: 

Tool to compare two SAPUI5 versions to check for deprecated objects?

BrendanFarthing
Participant

Hi,

Does anyone know of an automated tool for comparing two different SAPUI5 versions, specifically to look for what has been deprecated between those two versions? I don't want to do this manually by comparing documentation as it would be too time consuming.

For example, we would like to upgrade the SAPUI5 version we use from 1.84.27 to the latest 1.96.xx version and want to know what has been deprecated between those two versions so we can look for those APIs, Controls etc in all of our apps and adjust the code. We'd like to do that rather than just having user's test and hope they find all issues. Users would also test, but they may miss things, hence wanting to do this also in a more controlled way.

Note that i also played around with the UI5 Support Assistant but it doesn't seen useful enough for this task.

Thanks,

Brendan

Accepted Solutions (1)

Accepted Solutions (1)

boghyon
Product and Topic Expert
Product and Topic Expert

There are mainly three ways to learn about deprecated APIs between different versions:

Please note that the last #api/deprecated page lists only the APIs that are entirely deprecated with the JSDoc tag `@deprecated` in the source code. There are other APIs which are only partially deprecated while the API itself is not. So far, I'm aware of

Also, there are APIs that are not even partially deprecated yet, but still provide an `async` parameter (mostly `false` by default) and therefore might become partially deprecated in the future to further restrict the number of sync XHRs:

Make sure to pass `true` to `async` whenever possible.

Additionally, take a look at the relevant warning and error logs in the browser console reported by the latest UI5 1.x version. You might have to increase the log level to see the logs. If the reported issue is caused by the framework code itself, create an issue in https://github.com/SAP/openui5/issues (OpenUI5 code) or a customer case (SAPUI5 code).

For new SAPUI5 application projects, it is recommended to develop with TypeScript which can help identifying deprecated APIs immediately during the development time.

BrendanFarthing
Participant
0 Kudos

Thanks Boghyon, that's pretty much what I need. I didn't realise that functionality was there.

Answers (1)

Answers (1)

Marian_Zeis
Active Contributor

Hi Brendan,

this has always bugged me too and wanted to write a fast UI5 app to show the differences between UI5 versions.

I quickly wrote something that can help:

https://marianfoo.github.io/ui5-lib-diff/

Feel free to give feedback

BrendanFarthing
Participant
0 Kudos

Hi Marian,

I just had a quick look at your tool. That's nice! That's closer to the type of tool I was looking for.

I'll have a more detailed look and give you any feedback I have.

Regards,

Brendan

philipdavy
Contributor
0 Kudos

20eed143c19f4b82bc4cf049916102cb

Is the code for this project available as open source in Github ?