Showing results for 
Search instead for 
Did you mean: 

The base class includes the field 'CrystalReportViewer1', but its type...

Former Member
0 Kudos

Hi there,

I recently installed Visual Studio Ultimate 2010.

I currently have both VS 2005 and 2008 installed.

I downloaded and installed CRforVS_13_0_1.exe.

I created a simple C# web page with a Crystal Reports Viewer on it.

I get this error:

The base class includes the field 'CrystalReportViewer1', but its type (CrystalDecisions.Web.CrystalReportViewer) is not compatible with the type of control (CrystalDecisions.Web.CrystalReportViewer).

I did find some references to Crystal report 10 in my web.config and removed them. These are the only references:

<add assembly="CrystalDecisions.ReportAppServer.Controllers, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304"/>

<add assembly="CrystalDecisions.ReportAppServer.DataDefModel, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304"/>

<add assembly="CrystalDecisions.CrystalReports.Engine, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/>

<add assembly="CrystalDecisions.ReportSource, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/>

<add assembly="CrystalDecisions.Shared, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/>

<add assembly="CrystalDecisions.ReportAppServer.ClientDoc, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/>

My default.aspx page looks like this:

<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Default.aspx.cs" Inherits="COMET04._Default" %>

<%@ Register assembly="CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304" namespace="CrystalDecisions.Web" tagprefix="CR" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "">

<html xmlns="">

<head runat="server">




<form id="form1" runat="server">


<CR:CrystalReportViewer ID="CrystalReportViewer1" runat="server"

AutoDataBind="true" />





I can't see where I would be having any conflicts.

Does anyone know a solution to this?



Accepted Solutions (1)

Accepted Solutions (1)

Active Contributor
0 Kudos

Hello Ric,

I am not sure if you have downloaded and installed the [Crystal Reports basic for Visual Studio 2010|] as 'CRforVS_13_0_1.exe' is just a service pack for CR4VS2010.

If CR4VS2010 is installed, the viewer might be of the older version. Customize the toolbox and add the viewer of version 13.

As you have multiple Crystal versions installed on the same machine, all of these co-exist in the GAC. The problem is that you most likely have multiple references to CrystalDecisions.Web dll in the config file of your application. IE an additional reference was added to the <add assembly..../> tag in your web.config.

Delete all assembly references and add only version 13 references.

Hope it helps.



Answers (2)

Answers (2)

Former Member
0 Kudos


Well, brother, if you were like me and tried to open a Crystal Report for the first time in VS 2010, you got this really nice little page that told you about the SAP Crystal Reports for VS 2010 (vs 13.0.x) that you should download and install. So I did. Then I proceeded to my "toolbox" menu and added a Crystal Report Viewer control (and did some other stuff) and then ran it and behold... the dreaded error.

So, off we go to Bing (or Google) and search on this error and eventually wind up here on this page. After a long while of trying just about everything, I finally got it to work. I believe the answer is like one of the other fellas said about upgrading the Crystal Report runtime. Now, that didn't flash with me at first because I just downloaded the latest and greatest SAP CR version (13.0.x) and italics never ran it before, so surely I have the latest runtime and other fun things associated. Well, no, is the answer.

The quick solution: in VS 2010, add the CrystalReportViewer control, the CrystalReportSource (and anything else you could possibly want for the Crystal Report solution) into a new (or existing) project. Then save the project (and solution if you like). Now for the fun trick... open it (the solution file or project file) again with VS 2010 (ensure you did download and install the 13.0.x version prior to all of this!) and low and behold, VS 2010 says you're working with an older version of Crystal Reports... wanna upgrade? I bemusedly said, "Yes" and voila, the error goes away and the report runs.

So, my brother in frustration, the easy, quick and dirty solution in summary (again):

1) Ensure Crystal Reports 13.0.x for VS 2010 is installed.

2) Open (or create) a project and add all the Crystal Report components you want (for sure add CrystalReportsViewer and CrystalReportsSource

3) Save the project (and solution if you like)

4) Close VS 2010

5) Open VS 2010

6) Tell VS 2010 to open your project (or solution) from step 3

7) VS 2010 will say the version of Crystal Reports (from the controls you added from the toolbox) is older, wanna upgrade?

😎 Click "Yes".

9) Sit back in bewilderment as to how a brand new install is somehow outdated.

This worked for me, brother, and I hope it works for you, too.

Rock on.

Active Contributor
0 Kudos

Not sure. I do know that when I installed SP1, it just worked. No problems, easy peasy...


[original link is broken]

All I had to do afterwards when deploying was that I used SP1 runtime;

- Ludek

Active Contributor
0 Kudos

See KB 1544693 and 1544532. Use the search box - top right corner of this web page.

- Ludek

Former Member
0 Kudos

Same problem.

I have a VS2010 solution with 2 projects; 1 in, the other in C#. The Crystal viewer works fine in but I get this error in C#.

I've copied the web.config file from the project over to the C# project so the references are the same. But I still get this error. I can't find any references to Crystal 12.0. In the C# project.