cancel
Showing results for 
Search instead for 
Did you mean: 

Text size using the web viewer in Crystal Reports Visual Studio 2010

Former Member
0 Kudos
68

I have an application developed in Visual Studio 2010 which use reports edited with Crystal Reports 2011 and are generated using de Crystal Reports for Visual Studio 2010. The reports are used in both, windows application and in a web service belonging to the same solution. When I view the reports through the windows application the viewer shows the reports properly, but if I view the same reports through the web explorer (IIS7 local web server) the text fields or formula fields donu2019t respect the size assigned during the edition process. As a result the text overlap with each other. I try to install the last SP1 for CRVS2010 but the trouble persist.

There is any solution or special configuration for the web server viewer to avoid the problem?

Thanks.

View Entire Topic
former_member183750
Active Contributor
0 Kudos

See if enabling the option "Dissociate Formatting Page Size and Printer Paper Size" will help.

Ludek

Follow us on Twitter http://twitter.com/SAPCRNetSup

Got Enhancement ideas? Try the [SAP Idea Place|https://ideas.sap.com/community/products_and_solutions/crystalreports]

Former Member
0 Kudos

I try to modify the setting u201CDissociate Formatting Page Size and Printer Paper Sizeu201D in the report edition through Crystal Reports 2011 and after generate again the project but the behavior of the problem itu2019s the same. Anything I can do more?

Thanks for your response.

former_member183750
Active Contributor
0 Kudos

What browser are you using? IE? Firefox?

- Ludek

Former Member
0 Kudos

Iu2019m using Internet Explorer 8 to test the web application, but the problem occurs in Firefox 7.0.1 too

former_member183750
Active Contributor
0 Kudos

Do you see font substitution? E.g.; if the report was created using Arial font, is the font Times New Roman or other?

If I contact you over email, would you be able to share the report - with saved data?

Can you post a link to a screenshot of the issue?

- Ludek

Former Member
0 Kudos

We test font substitution but the problem appears in the same wayu2026 With the windows viewer works correctly, so we understand that is a problem with the viewer for the web.

Of course you can contact us over email and we will attach an example of report with saved data and screenshot showing the trouble. In fact we sent a reply to the u201CSAP Forumsu201D notifier email but we donu2019t kwon if you receive it.

Thanks in advance for your help.

former_member183750
Active Contributor
0 Kudos

Hello Jose

Not at all sure where "SAP Forums notifier email" goes to, but it sure don't go to me

Anyhow, I'll email you from my personal email account. My suspicion is that this is a font access problem. Particularly if this works in a win app and not a web app. Also, I believe most other web app developers don't see this issue either. E.g.; make sure the worker process has access to the fonts. If I was a betting man, I'd bet when I get your reports here and run them, they will be just fine. But let's take a look and see.

- Ludek