cancel
Showing results for 
Search instead for 
Did you mean: 

TabStrip does not render correct

Thilo
Explorer
0 Kudos

Take a look at this examble:

<htmlb:tabStrip id = "Ts1">
    <htmlb:tabStripItem id       = "TsItem1"
                        title    = "Tab 1"
                        index    = "1" >
        <htmlb:tabStripItemBody>
            Body
        </htmlb:tabStripItemBody>
    </htmlb:tabStripItem>
</htmlb:tabStrip>

does render to:

<input name="cont_SMS_SMSSUB_Ts1_num" id="cont_SMS_SMSSUB_Ts1_num" type="hidden" value="1">
<input name="cont_SMS_SMSSUB_Ts1_sel" id="cont_SMS_SMSSUB_Ts1_sel" type="hidden" value="1">
<input name="cont_SMS_SMSSUB_Ts1_idx" id="cont_SMS_SMSSUB_Ts1_idx" type="hidden" value="1">
<table cellspacing="0" cellpadding="0" border="0" width="400">
	<tr valign="top">
		<td>
			<table cellspacing="0" cellpadding="0" border="0">
				<tr>
					<td id="cont_SMS_SMSSUB_Ts1tab1" class="sapTbsTabSel"><a onMouseOver='this.style.cursor="hand";window.status=""; return true;' onMouseOut='window.status=""; return true;' href="javascript:void(0)" onclick="sapTbs_switch(1,1,'cont_SMS_SMSSUB_Ts1'); return false;" style="text-decoration:none"><span class="sapTxtStd" id="1__cont_SMS_SMSSUB_Ts1__Title" header="Tab 1"><nobr>Tab 1</nobr></span></a></td>
					<td id="cont_SMS_SMSSUB_Ts1tbsImg1" class="sapTbsSpcFrOn"><img src="/sap/public/bsp/sap/public/bc/htmlb/1x1.gif" border="0" width="1"></td>
					<td nowrap id="cont_SMS_SMSSUB_Ts1tbsImg2" class="sapTbsSpcBkOff"></td>
					<td nowrap class="sapTbsTabBlk"> </td>
				</tr>
			</table>
			<table cellpadding="0" cellspacing="0" class="sapTbsWhl" border="0" width="100%">
				<tr>
					<td>
						<div id="cont_SMS_SMSSUB_Ts1content1" class="sapTbsDsp" style="width:100%;display:block;">
							Body
						</div>
					</td>
				</tr>
			</table>
		</td>
	</tr>
</table>
</span>

Where is the start tag of the very last span?

By the way, an ID starting with a number ist not legal in HTML – see span class="sapTxtStd" id="1__cont_SMS_SMSSUB_Ts1__Title"…

WAS 6.40 SP 9

Design CLASSIC

Regards,

Thilo

Accepted Solutions (1)

Accepted Solutions (1)

former_member181879
Active Contributor
0 Kudos

Hallo Thilo,

Yes, sometimes even I am amazed at the HTML that is given to use to render. You are right that the <span> is missing. Just for the record: design CLASSIC is not really used anymore for a long time. Our recommendation would be in all cases to switch to design2003. If you the same rendering problems with these, route an OSS message over to us, and we will forward it to our HTML rendering team.

brian

Answers (0)