cancel
Showing results for 
Search instead for 
Did you mean: 

system copy ,dispatcher not up

Former Member
0 Kudos

Dera all

I have completed system copy

database proper open but dispater is down after some time

please find the log details

-


trc file: "dev_w0", trc level: 1, release: "640"

-


*

  • ACTIVE TRACE LEVEL 1

  • ACTIVE TRACE COMPONENTS all, M

*

B

B Tue Feb 12 17:01:09 2008

B create_con (con_name=R/3)

B Loading DB library 'C:\usr\sap\DEV\SYS\exe\run\dboraslib.dll' ...

B Library 'C:\usr\sap\DEV\SYS\exe\run\dboraslib.dll' loaded

B Version of 'C:\usr\sap\DEV\SYS\exe\run\dboraslib.dll' is "640.00", patchlevel (0.172)

B New connection 0 created

M sysno 31

M sid DEV

M systemid 560 (PC with Windows NT)

M relno 6400

M patchlevel 0

M patchno 203

M intno 20020600

M make: multithreaded, Unicode

M pid 4220

M

M ***LOG Q0Q=> tskh_init, WPStart (Workproc 0 4220) [dpxxdisp.c 1162]

I MtxInit: -2 0 0

M DpSysAdmExtCreate: ABAP is active

M DpShMCreate: sizeof(wp_adm) 10560 (1320)

M DpShMCreate: sizeof(tm_adm) 2969176 (14772)

M DpShMCreate: sizeof(wp_ca_adm) 24000 (80)

M DpShMCreate: sizeof(appc_ca_adm) 8000 (80)

M DpShMCreate: sizeof(comm_adm) 290000 (580)

M DpShMCreate: sizeof(vmc_adm) 0 (424)

M DpShMCreate: sizeof(wall_adm) (38456/34360/64/184)

M DpShMCreate: SHM_DP_ADM_KEY (addr: 06500040, size: 3381712)

M DpShMCreate: allocated sys_adm at 06500040

M DpShMCreate: allocated wp_adm at 06501B88

M DpShMCreate: allocated tm_adm_list at 065044C8

M DpShMCreate: allocated tm_adm at 065044F0

M DpShMCreate: allocated wp_ca_adm at 067D9348

M DpShMCreate: allocated appc_ca_adm at 067DF108

M DpShMCreate: allocated comm_adm_list at 067E1048

M DpShMCreate: allocated comm_adm at 067E1060

M DpShMCreate: allocated vmc_adm_list at 06827D30

M DpShMCreate: system runs without vmc_adm

M DpShMCreate: allocated ca_info at 06827D58

M DpShMCreate: allocated wall_adm at 06827D60

M ThTaskStatus: rdisp/reset_online_during_debug 0

X EmInit: MmSetImplementation( 2 ).

X <ES> client 0 initializing ....

X Using implementation flat

M <EsNT> Memory Reset disabled as NT default

X ES initialized.

M

M Tue Feb 12 17:01:10 2008

M calling db_connect ...

C Prepending C:\oracle\ora92 to Path.

C got NLS_LANG='AMERICAN_AMERICA.UTF8' from environment

C Client NLS settings: AMERICAN_AMERICA.UTF8

C Logon as OPS$-user to get SAPDEV's password

C Connecting as /@DEV on connection 0 (nls_hdl 0) ... (dbsl 640 250407)

C Nls CharacterSet NationalCharSet C EnvHp ErrHp ErrHpBatch

C 0 UTF8 1 05874F18 05879FD8 05879A40

C Attaching to DB Server DEV (con_hdl=0,svchp=05879994,srvhp=057DF054)

C

C Tue Feb 12 17:01:11 2008

C Starting user session (con_hdl=0,svchp=05879994,srvhp=057DF054,usrhp=0970F368)

C *** ERROR => OCI-call 'OCISessionBegin' failed: rc = 1017

[dboci.c 4502]

C *** ERROR => CONNECT failed with sql error '1017'

[dbsloci.c 11404]

C Try to connect with default password

C Connecting as SAPDEV/<pwd>@DEV on connection 0 (nls_hdl 0) ... (dbsl 640 250407)

C Nls CharacterSet NationalCharSet C EnvHp ErrHp ErrHpBatch

C 0 UTF8 1 05874F18 05879FD8 05879A40

C Starting user session (con_hdl=0,svchp=05879994,srvhp=057DF054,usrhp=0970F368)

C *** ERROR => OCI-call 'OCISessionBegin' failed: rc = 1017

[dboci.c 4502]

C *** ERROR => CONNECT failed with sql error '1017'

[dbsloci.c 11404]

B ***LOG BY2=> sql error 1017 performing CON [dbsh#3 @ 1204] [dbsh 1204 ]

B ***LOG BY0=> ORA-01017: invalid username/password; logon denied [dbsh#3 @ 1204] [dbsh 1204 ]

B ***LOG BY2=> sql error 1017 performing CON [dblink#3 @ 428] [dblink 0428 ]

B ***LOG BY0=> ORA-01017: invalid username/password; logon denied [dblink#3 @ 428] [dblink 0428 ]

M ***LOG R19=> tskh_init, db_connect ( DB-Connect 000256) [thxxhead.c 1280]

M in_ThErrHandle: 1

M *** ERROR => tskh_init: db_connect (step 1, th_errno 13, action 3, level 1) [thxxhead.c 9621]

M

M Info for wp 0

M

M stat = 4

M reqtype = 1

M act_reqtype = -1

M rq_info = 0

M tid = -1

M mode = 255

M len = -1

M rq_id = 65535

M rq_source = 255

M last_tid = 0

M last_mode = 0

M int_checked_resource(RFC) = 0

M ext_checked_resource(RFC) = 0

M int_checked_resource(HTTP) = 0

M ext_checked_resource(HTTP) = 0

M report = > <

M action = 0

M tab_name = > <

M

M *****************************************************************************

M *

M * LOCATION SAP-Server qwdsvr_DEV_31 on host qwdsvr (wp 0)

M * ERROR tskh_init: db_connect

M *

M * TIME Tue Feb 12 17:01:11 2008

M * RELEASE 640

M * COMPONENT Taskhandler

M * VERSION 1

M * RC 13

M * MODULE thxxhead.c

M * LINE 9806

M * COUNTER 1

M *

M *****************************************************************************

M

M PfStatDisconnect: disconnect statistics

M Entering TH_CALLHOOKS

M ThCallHooks: call hook >ThrSaveSPAFields< for event BEFORE_DUMP

M *** ERROR => ThrSaveSPAFields: no valid thr_wpadm [thxxrun1.c 730]

M *** ERROR => ThCallHooks: event handler ThrSaveSPAFields for event BEFORE_DUMP failed [thxxtool3.c 255]

M Entering ThSetStatError

M Entering ThReadDetachMode

M call ThrShutDown (1)...

M ***LOG Q02=> wp_halt, WPStop (Workproc 0 4220) [dpnttool.c 357]

thanks

venkat

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Dear Venkat,

For temporary solution, you can reset the user sapdev with password default "sap" from brtools.

And please also run the command:

sqlplus /nolog @sapdba_role.sql

from your /usr/sap/<SID>/SYS/exe/run

And try again.

Regards,

Fendi

Former Member
0 Kudos

Dear Fendi

I change the password but problem is not resolve

when i excute the commnd ,Please find the details

C:\>sqlplus /nolog

SQL*Plus: Release 9.2.0.7.0 - Production on Tue Feb 12 18:22:05 2008

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

SQL> conn /as sysdba

Connected.

C:\>sqlplus /nolog @sapdba_role.sql

SQL*Plus: Release 9.2.0.7.0 - Production on Tue Feb 12 18:23:39 2008

Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

SP2-0310: unable to open file "sapdba_role.sql"

SQL>

regards

venkat

markus_doehr2
Active Contributor
0 Kudos

Is that script in the directory you are calling sqlplus from?

Markus

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi,

did you try following

-- in sql try to login with sqlplus “ connect / as sysdba” ? is logon sucessfull?

-- what is a value of SQLNET.AUTHENTICATION_SERVICES in sqlnet.ora

regards,

kaushal

Former Member
0 Kudos

Dear

case1- login successfully

case2

sqlnet.ora file details

################

  1. Filename......: sqlnet.ora

  2. Created.......: created by SAP AG, R/3 Rel. >= 6.10

  3. Name..........:

  4. Date..........:

  5. @(#) $Id: //bc/640-2/src/ins/SAPINST/impl/tpls/ora/ind/SQLNET.ORA#4 $

################

AUTOMATIC_IPC = ON

TRACE_LEVEL_CLIENT = OFF

NAMES.DEFAULT_DOMAIN = WORLD

NAME.DEFAULT_ZONE = WORLD

SQLNET.EXPIRE_TIME = 0

SQLNET.AUTHENTICATION_SERVICES = (NTS)

TCP.NODELAY=YES

regards

venkat