cancel
Showing results for 
Search instead for 
Did you mean: 

SUP 2.0 and operation with input table scenario.

Former Member
0 Kudos
42

Hello,

I created an mbo in sup 2.0 with an operation that takes as input a table type. The operation is mapped to a remote RFC (but I have also tried to map it to a webservice with the same results).

SUP has self-generated a structure that represents a row in the table, and uses it to power the operation.

During the "test execute" I get the following error: "Execution failed: null" and the rfc is not called on backend (SAP).

I also tried to create a workflow with a listview that displays the elements of the table, and a menu item that performs an "online request" invoking the operation, and passing it the key associated with the listview. In this case the operation is called on the backend, but the table comes completely empty.

So, I tried to do the same thing with a structure in input to the operation rather than a table. Again, SUP generates itself a support structure, but in this case, data are sent to the rfc (using workflow) and the "execute test 'works fine!

Has anyone had the same problem?

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Alessandro,

I know your post is a bit old, but as I just had the same problem I thought my answer could maybe help somebody else.

It seemed very strange for SUP to have such a limitation, with all it's "bads" so as expected the solution is a very simple one:

just replace the table parameter's default {"","",""} with <NULL> from the dropdown and your test execution will be successfull.

Hopefully useful,

Mihai

Former Member
0 Kudos

Alessandro,

I had the same problem, i solved when i use the obsolet mode to declare a table in SE37, you need declare your table in table tab not as a input ou output parameter, i guess that is a bug a need to be treated on the next versios.

Regards.