cancel
Showing results for 
Search instead for 
Did you mean: 

Sum of Invoice value in the report is showing on the upper side

Former Member
0 Kudos

Hi Experts,

I have created z report. In my report I have 3 columns i.e. vendor , product category, Invoice Value.

In my report the output is coming in some wierd style like the result(sum) of Invoice value regarding to any particular vendor is coming on the upper side.

Usually it must show at the bottom of one vendor containing all product categories.

For ex. The cureent output as:

vendor--


product category--


Invoice Value

A--


Result--


125

-


A1----


100

-


A2----


25

B--


A3--


200

I want output like:

vendor--


product category--


Invoice Value

A--


A1--


100

-


A2----


25

-


Result----


125

B--


A3--


200

Please suggest.

Thanks and Regards,

Niranjan Chechani

Edited by: Niranjan Chechani on Jan 30, 2012 2:18 PM

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi

open the properties for your product category in query designer, in display tab for results rows select "display if more than one value" and save it.

Now execute the query, this should give the results as expected.

Regards,

Venkatesh

Former Member
0 Kudos

Hi All,

I tried all the suggested ways. The 2nd column of my report has hierarchy.

So is it for every hierarchy it wil show Result on the upper side and then values?

Explaination:

vendor--


UNSPSC (Hierarchy)--


Invoice Value

A--


Result--


125

-


A1----


100

-


A2----


25

B--


A3--


200

I want output like:

vendor--


UNSPSC (Hierarchy)--


Invoice Value

A--


A1--


100

-


A2----


25

-


Result----


125

B--


A3--


200

Regards,

Niranjan Chechani

Edited by: Niranjan Chechani on Jan 31, 2012 2:03 PM

Former Member
0 Kudos

Hi,

In the Query Properties (Bex Analyser) go to the tab Presentation Options select position of result in Columns you can see as below.

Specify the position in the columns in which you want to display the results.

● Bottom (default)

● Top

For more details Please check http://help.sap.com/saphelp_nw70/helpdata/en/f1/0a5529e09411d2acb90000e829fbfe/content.htm

Edited by: Dexter123 on Jan 31, 2012 6:46 PM

Former Member
0 Kudos

Hi Dexter123,

I checked the same and it is selected as bottom only. But still the result is same.

Is it because of hierarchy?

Regards,

Niranjan Chechani

Former Member
0 Kudos

Hi,

This may be because of Hierarchy.

You can try changing the setting in heirarchy.

Open infoobject, open hierarchy maintenance->

Click on hierarchy attributes.

Edit Display Parameters for Hierarchy Display in Query:

Select radio button:Root/Totals Item Appears Below. Initially it might be selected as Above.

Hope this helps.

Regards

Jeeth

Former Member
0 Kudos

Hi Jeeth,

Sorry to late reply. I did the correction as u suggested. It solved my problem.

Points are assigned.

Thanks and Regards,

Niranjan Chechani

Answers (2)

Answers (2)

anshu_lilhori
Active Contributor
0 Kudos

Hi,

I think you have selected Result rows display as above from query properties.Please check the same and change it to bottom.

Refer the below link for more understanding.

http://help.sap.com/saphelp_nw70/helpdata/en/d2/02223c5f00612be10000000a11402f/frameset.htm

Hope it helps.

Regards,

AL

former_member188080
Active Contributor
0 Kudos

Hi,

In the query property you can define where exactly you want show the result whether it is top right or bottom left and so on..

or you also need to define based on certain charatersitics say vendor ... then you can right click on the field and select the property.. there that result to be shown always...

Thanks and regards

Kiran