cancel
Showing results for 
Search instead for 
Did you mean: 

Subreport displays partial data

Former Member
0 Kudos

Hi,

I have a list of crystal reports that are being converted from version 9 to 11. These reports are called from .Net 3.5 Web app. There are few reports which have subreports in it. In one of the subreport, a data field is retrieved from Oracle database and used for display. This data field is not a physical field in any Oracle table. Instead, it's a manipulated field (like "20" as Sort_Order) from Oracle DB. When the field value is displayed during runtime, only partial data is displayed. For example, the actual value returned from DB is 201002. But this field shows only 20 during runtime in subreport. But, during preview, the complete (201002) value is displayed.

Please help.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

Sorry for the delayed response. Yes, we use CR 11 with VS 2008. We are using the following references in our app.

using CrystalDecisions.CrystalReports.Engine;

using CrystalDecisions.Shared;

We are creating a reportobject, adding params to it and loading the CR.

Adding to above, recently we created a new CR 11 report where we added a subreport and drag and dropped the DB column to the group header in that subreport. we called this report from our app and it shows the data correctly. Only our existing report is not showing the full data. What may be the cause of this issue. Please help. Thanks in advance.

former_member183750
Active Contributor
0 Kudos

Only version 12.x and version 10.5 of Crystal Reports are supported in .NET 2008.

See [this|https://wiki.sdn.sap.com/wiki/pages/viewpage.action?pageId=64259646] wiki for more details.

Ludek

Answers (1)

Answers (1)

former_member183750
Active Contributor
0 Kudos

Are you using CR 11 with .NET 2008? E.g; what is the version of the CR references in your project - say, crystaldecisions.crystalreports.engine.dll?

Ludek

Follow us on Twitter http://twitter.com/SAPCRNetSup