cancel
Showing results for 
Search instead for 
Did you mean: 

Standard Single Host Installation of SAP ERP 6 EHP8 using Oracle DB 19c on Oracle Linux Host

HemantVaswani
Explorer

Hi Friends,

I am building a fresh SAP ECC system using the ERP 6 EHP8 using Oracle DB 19c.

Cloud Environment: AWS EC2 instance type r5.8xlarge (32vCPU and 256GB RAM.

OS : Oracle Linux 8.9 x86_64 (AWS AMI - ami-076b18946a12c27d6)

I have arranged the following disk partitions

[root@sap-ora-demo ~]# lsblk

NAME        MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT

nvme1n1     259:0    0  100G  0 disk /sapmnt

nvme8n1     259:1    0   20G  0 disk

nvme6n1     259:2    0  500G  0 disk /usr/sap/backup

nvme5n1     259:3    0  200G  0 disk /usr/sap

nvme7n1     259:4    0  100G  0 disk

nvme4n1     259:5    0  250G  0 disk [SWAP]

nvme2n1     259:6    0   50G  0 disk

nvme3n1     259:7    0   20G  0 disk

nvme0n1     259:8    0   50G  0 disk

└─nvme0n1p1 259:9    0   50G  0 part /

 

df -hT

Filesystem                                         Type                       Size       Used     Avail     Use%                    Mounted on

devtmpfs                                           devtmpfs            125G     0             125G     0%                         /dev

tmpfs                                                    tmpfs                    125G     0             125G     0%                         /dev/shm

tmpfs                                                    tmpfs                    125G     8.6M     125G     1%                         /run

tmpfs                                                    tmpfs                    125G     0             125G     0%                         /sys/fs/cgroup

/dev/nvme0n1p1                            xfs                          50G       13G       38G       26%                       /

/dev/nvme1n1                                 xfs                          100G    747M    100G   1%                         /sapmnt

/dev/nvme5n1                                 xfs                          200G    1.5G      199G    1%                         /usr/sap

/dev/nvme6n1                                  xfs                          500G    3.6G      497G    1%                         /usr/sap/backup

AWS EFS storage                            nfs4                       8.0E       59G       8.0E       1%                         /usr/sap/trans

Tmpfs                                                   tmpfs                    25G       0             25G       0%                         /run/user/1000

 

I have updated the OS packages and installed the following:

Unzip, nfs-utils, awscliv2, uuidd,

 

Performed prerequisites check using the SWPM (sapinst) for

SAP Business Suite 7i 2016 > EHP8 for SAP ERP 6 ABAP > Oracle >Preparations

Installed the Oracle 19c software remotely by using the mobaxterm utility, ssh session & x11 forwarding.

HemantVaswani_0-1715958446992.png

Further proceeded for installation using the SWPM (sapinst) for

SAP Business Suite 7i 2016 > EHP8 for SAP ERP 6 ABAP > Oracle >Installation> Application Server ABAP>Standard System >Standard System

Installed the Oracle DB exports using patch from

HemantVaswani_1-1715958447002.png

Maintained the same SID as for the DB software.

Almost during the end of “define parameters” phase of SWPM process, I am getting the following message.

HemantVaswani_0-1715959264360.png

 

An error occurred while processing option SAP Business Suite 7i 2016 > EHP8 for SAP ERP 6.0 ABAP > Oracle > Installation > Application Server ABAP > Standard System > Standard System (Last error reported by the step: Execution of the command "rsecssfx/rsecssfx generatekey -keyId 20240516_172333_SBX_INSTALLER -getPlainValueToConsole" finished with return code 1. Output: rsecssfx/rsecssfx: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by rsecssfx/rsecssfx)).

You can now:

Choose Retry

to repeat the current step.

Choose Log Files

to get more information about the error.

Stop the option and continue later.

Log files are written to /tmp/sapinst_instdir/BS2016/ERP608/ORA/INSTALL/STD/ABAP.

 

Error found in above path : sapinst_dev.log :

ERROR   2024-05-16 18:54:07.884 (root/sapinst) (startInstallation) [CSiStepExecute.cpp:1105] id=controller.stepExecuted errno=FCO-00011 CSiStepExecute::execute() The step generateKey with step key |NW_ABAP_OneHost|ind|ind|ind|ind|0|0|NW_Onehost_System|ind|ind|ind|ind|onehost|0|NW_CI_Instance|ind|ind|ind|ind|ci|0|NW_ABAP_SSFS_Custom_Key|ind|ind|ind|ind|customKey|0|generateKey was executed with status ERROR (Last error reported by the step: Execution of the command "rsecssfx/rsecssfx generatekey -keyId 20240516_185407_SBX_INSTALLER -getPlainValueToConsole" finished with return code 1. Output: rsecssfx/rsecssfx: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by rsecssfx/rsecssfx)).

 

Actions taken.

  1. tried installation of

-rwxrwxrwx 1 root root 68303162 May 16 13:10 compat-sap-c++-10-10.2.1-11.0.3.el8.src.rpm

Got output as:

warning: user mockbuild does not exist - using root.

warning: group mock does not exist - using root.

checked following.

[root@sap-ora-demo ABAP]# bash

[root@sap-ora-demo ABAP]# strings /usr/lib64/libstdc++.so.6 | grep GLIBCXX

GLIBCXX_3.4

GLIBCXX_3.4.1

GLIBCXX_3.4.2

GLIBCXX_3.4.3

GLIBCXX_3.4.4

GLIBCXX_3.4.5

GLIBCXX_3.4.6

GLIBCXX_3.4.7

GLIBCXX_3.4.8

GLIBCXX_3.4.9

GLIBCXX_3.4.10

GLIBCXX_3.4.11

GLIBCXX_3.4.12

GLIBCXX_3.4.13

GLIBCXX_3.4.14

GLIBCXX_3.4.15

GLIBCXX_3.4.16

GLIBCXX_3.4.17

GLIBCXX_3.4.18

GLIBCXX_3.4.19

GLIBCXX_3.4.20

GLIBCXX_3.4.21

GLIBCXX_3.4.22

GLIBCXX_3.4.23

GLIBCXX_3.4.24

GLIBCXX_3.4.25

GLIBCXX_DEBUG_MESSAGE_LENGTH

GA+GLIBCXX_ASSERTIONS

 

  1. tried re-run of SWPM with following
  2.  simple master password   , none special character , total 8 character
  3. unchecked “use ABAP SSFS” option in one of the SWPM step.

Still facing same error

View Entire Topic
HemantVaswani
Explorer
0 Kudos

Hi,

After refering the SAP note 3119751, I downloaded the following file from Oracle enterprise support portal :

compat-sap-c++-10-10.2.1-11.0.3.el8.src.rpm

However while installing this package, I got this warning message:

warning: user mockbuild does not exist - using root.

warning: group mock does not exist - using root.

I presume the package is installed.

 

Kindly suggest. If possible can you please try to share the package here since it's a small filesize. 

Thank you 

Hemant

HemantVaswani
Explorer
0 Kudos

I have created the user mockbuild and added the  user mock.

executed rpm -i compat-sap-c++-10-10.2.1-11.0.3.el8.src.rpm, didn't receive any error nor any message of installation completed.

However, even after freshly starting the SWPM installation, the error message remains same.