cancel
Showing results for 
Search instead for 
Did you mean: 

SSAM Android Client build fails (SSAM 2310 + MDK 23.8.7)

a_kingston
Explorer
0 Kudos

Hello Team,

I'm trying to create an SSAM 2310 Client for Android, and all the Android dependencies are fine. However, when I create the client using the 'create-client' command, I get an "Failed to run ns build android" with below error. Could anyone please provide some insights or suggestions to resolve this issue?

Screenshot 2024-04-11 105241.png

Thank you very much in advance,
Kingston. A

View Entire Topic
muhammad_rafay
Advisor
Advisor
0 Kudos

You might not be using the 2310 branding sdk. Inside the Branding SDK, there is a folder SAM.mdkproject/App_Resources_Merge/Android/app.gradle. Check if that app.gradle contains 

defaultConfig {
    minSdkVersion 30
    targetSdkVersion 33
}

 

a_kingston
Explorer
0 Kudos
Hi muhammad_rafay ! I'm not able to find the `app.gradle` file in the 2310 branding SDK folder. I only found the `AndroidManifest.xml` file. The folder path is like this `\SAPAssetManager\SAM.mdkproject\App_Resources_Merge\Android\src\main\AndroidManifest.xml`
muhammad_rafay
Advisor
Advisor
0 Kudos
The file is there inside 2310.0.2 branding SDK