cancel
Showing results for 
Search instead for 
Did you mean: 

SRT 031 Empty SOAP Message received

Former Member
0 Kudos
639

Hello,

I have an external Web service wich it works under SOAPui, but when I generate a Proxy and a port in SAP using the WSDL file , and then i try to test it I have this error message.

SOAP:1 031 SRT: Empty SOAP message received

How can I solve this problem?

Thanks in Advance.

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Have you managed to find an answer to your problem? We are facing exactly the same issue on our project.

Merci d'avance.

Former Member
0 Kudos

Hi,

No We still having the same problem.

We think that the problem source is the port number on wich the service is deployed (8090), we tried on the port (80) and the tests was OK.

jitendra_it
Active Contributor
0 Kudos

Hi Thierry,

check my reply in below thread.

Many Thanks,

Jitendra Soni

TonyRosenthal
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Jitendra,

We are having similar problems, we're getting the SRT 031 Empty SOAP Message received error but the RFC destination is set up OK.

Running the same webservice from other tools gets a response OK, so the issue must be on the ABAP/SOAManager side of things

Do you have any more ideas of how to troubleshoot this?

Thanks in advance

Tony

Former Member
0 Kudos

Hi,

Does anyone got the solution for this problem?We still having the same problem with a service deployed on port 8090

Thanks