cancel
Showing results for 
Search instead for 
Did you mean: 

SQ01 and SE93

David
Advisor
Advisor
0 Kudos

Trying to add a bespoke transaction code to a query I have created via SQ01. I ran the query and got the code behind it from System->Status. I then added the program name and screen 1000 to the transaction. The quesry and the transaction were then transaported into the QAS box. When I run the transaction in QAS I get a run time error where it says a field-symbol has not been assigned. The field-symbol is assigned in the initialisation block of the program. Have I done something wrong when assigning the query to the transaction code as when I run the query in QAS vie SQ01 all runs fine.

Accepted Solutions (0)

Answers (2)

Answers (2)

former_member181966
Active Contributor
0 Kudos

You must be missing something

1- Go to SQ01 select query name and then go to

Query ->more functions - > gen.program

2- Do you have any default variant define in Query ( SQ01 )?

if yes , also give it in Tcode in SE93 . If you don’t have as a test create a var and assign it in your t-code and see .

Only thing I can think of there’s some discrepancy in Query .

Pl..award the points

Thanks

LucianoBentiveg
Active Contributor
0 Kudos

Try to create a "Parameter Transaction" to transaction START_REPORT with parameters:

D_SREPOVARI-REPORTTYPE = 'AQ' (Query)

D_SREPOVARI-REPORT = query name.

Good Luck