cancel
Showing results for 
Search instead for 
Did you mean: 

SPS9- Firefox cannot open new window in Bex web analyzer-chetan or someone

Former Member
0 Kudos

Hello Prakash,

I went through your blog for 2004s Front end installation, which was last updated on 7/26/2006. We are currently on SPS9 on BI and Portal. We are trying to work with Firefox browser to see if the BI/portal functionalities work (if not the same way) as in Internet explorer. And what i am running into with Bex web analyzer, The new window that should opens up when you use New analysis or save as (pops are allowed on this site) does not open and it says the "This application does not support this browser: Netscape 5.0 (Windows; en-US)"

Neither Firefox 1.0 nor Firefox 1.5 are working with BEx Web Analyzer.

Can you throw some light or what are the avenues we can check before going ahead and trying to troubleshoot this issues.

Thanks in advance,

Kiran.

Any suggestions from anyone, anyone trying firefox?

Message was edited by:

Kiran Mehendale

Accepted Solutions (0)

Answers (3)

Answers (3)

jill_diesman
Participant
0 Kudos

Hello,

I am working on the same project team as Kiran, who started this thread.

My best lead right now is a javascript function that apparently opens the dialog

window when the New Analysis button is clicked.

I went to Bex Web Analyzer and viewed the source code for the content area

page. Among the included javascript files is sapbi_dialogsHandler.js, which is

located in:

j2ee\cluster\server0\apps\sap.com\irj\servlet_jsp\irj\root\portalapps\com.sap.ip.bi.web.portal.mimes\dialogsframework\resources\js

Here is a stripped-down excerpt from the file:

// Event Handling for BI Web Dialogs 
// (c) 2003, SAP AG

/**
 * Internal function to open a dialog which does not manipulate the global event object.
 */

function sapbi_DoOpenDialog(pl)
{
...       
if(sapbi_DIALOG_MODE_MODAL == windowmode)
{
    if(sapbi_page.m_browser.getType() == sapbi_BROWSER_TYPE_IE && sapbi_page.m_browser.getVersion() >= 5)
    {
    ...
    return true;
    } // if IE
        
    else
    {       //Netscape
        if( sapbi_page.m_browser.getType() == sapbi_BROWSER_TYPE_GECKO && sapbi_page.m_browser.getVersion() >= 6 )
        {
            // workaround to open a dialog in a dialog: use a random id
            var dlgNN1 = window.open(url,sapbi_createRandomId(), "width=" + dlgWidth + ",height=" + dlgHeight + ",modal=yes,status=no,resizable=no,scrollbars=yes");
            return true;
        } 
        else
        {
            alert("This application does not support this browser:  " + navigator.appName + " " + navigator.appVersion);  
            return false;
        }
    } // NN
}
else  // if not modal
{
    ...
}
}

I made a change to the function to determine whether I was dealing with the right

script and function. I changed the Netscape-specific

if( )

statement

above to check only for browser version >= 1 (I didn't include checking browser

type). When I tried to do New Analysis again in Firefox, I didn't get the popup

message and was able to look for queries, InfoProviders, etc.

So it seems like we have the culprit. However it seems like we shouldn't have to

manually modify that .js file, and that's not our first choice anyway. Can anyone

provide some insight into <b>how and when the sapbi_dialogsHandler.js file is

generated?</b> Based on the copyright year and the browser versions it's

checking for, it looks like an old script.

We did notice a similarity between the date/time stamp on this file and the

date/time of the transport for our standard Web Templates. For example, on our

QA portal+BI Java system the file was last updated 11/22/2006, which is the

same date we transported our standard Web Template into our QA BW ABAP

system. On our Production portal system the file was last updated 1/11/2007,

which is the same date we transported our standard Web Template into our

Production BW ABAP system.

Thanks for your help!

Jill

Former Member
0 Kudos

Just a update on this post.

We logged a message with SAP, there is patch 16 (SPS9) released for BI Java applying that patch resolves the use of BI applications on Firefox browser.

Note 1022703 takes care of the issue.

Thanks for all your replies.

Kiran

Former Member
0 Kudos

Thanks for the update ...

Chetan

@CP..

Former Member
0 Kudos

Kiran,

I just tested in Firefox 2.0 and everythign works as it should. I get popups for New Analysis and others. Everthing seems to be working as it is in IE.

I am running on SP10 with FEP 11.

Mike

Former Member
0 Kudos

Hi Kiran,

I would be candid to say never worked with fire fox ;the only person who I think can answer would be Prakash ,pls. wait for his response or if any one whos worked might worth sharing.

I remember once identifying the browser type(different from IE and then routing back to IE) through Javascript code.However this is not your requirement.

Sorry cant help much

Hope it Helps

Chetan

@CP..