cancel
Showing results for 
Search instead for 
Did you mean: 

SOTR_EDIT texts do not show in Poral even though transported

Former Member
0 Kudos

Dear all,

we are using SAP CRM 5.0, Support package level 4 & Enterprise Portal 7.0. We have programmed several reports with ABAB-Webdynpro. We are facing a problem. Changes in texts for these reports that we have fullfilled in tx SOTR_EDIT are not displayed in the report in our test-portal after transporting them there from our development-system. We normally simply transport the changes made in the texts and they are displayed correctly after transporting. This time we did the same thing and the transports seem to have worked just fine (checked all of the texts in our test-system and they are just what we transported - the equal the texts in the development system).

But now we always only see a very old version of the texts in the portal instead of the changes we just transported... So there seems to be a communication problem: By looking at SOTR_EDIT they seem to have been transported to the test-system. But looking at the portal you only see the very old version of texts.

Do you have any idea where else I could look?

We already restarted our Testportal, transported the texts again, invalidated the global HTTP-Server-Cache, let report CRM_BSP_STATE_ERASE run, cleaned the IE cache. I'm thinking that some table entry might be missing or do I still have to generate somethingP I cannot find the source of the problem...

Thank you very much for your help!

Regards,

Hauke

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

did you reset your OTR buffer? See SAP note 1048263

Regards, Heidi

Former Member
0 Kudos

Hello Heidi,

thank you for your answer Unfortunately this did not work. Also looked at the related notes…

438107 - Änderungen an Text werden zur Laufzeit nicht berücksichtigt

448220 - OTR: Text nicht gefunden/falscher Text angezeigt

... but without success. But thank you for the note anyways because I had not known the SOTR-transaction before. Is there some other sort of Cache I might have to empty out? The thing is that we always transported changes in the reports and never had to do any actions like this. It simply displayed all of the changes right away...

Kind regards,

Hauke

Former Member
0 Kudos

Hello Heidi,

solved the problem. Note 448220 was the correct one after all. You have to execute the report SOTR_DEFAULT_CONTEXT_FLAG_SET (in your test system after transporting) and after that set back the OTR-Buffer by typing in /$OTR into the transaction code bar. Then press enter.

Now all the changes that were stuck before are visible in our testsystem after transporting...

Regards and thanks again,

Hauke

Former Member
0 Kudos

Hi,

in this case, better close this thread.

Regards, Heidi

Answers (0)