cancel
Showing results for 
Search instead for 
Did you mean: 

Sorting in input help - not logical

Former Member
0 Kudos

Hello,

question for the frontend experts: Why do I receive the following result in the input help:

12 R4 1,9l 118KW T

12 R4 1,9l 55KW TDI

12 R4 1,9l 63KW TDI

12 R4 1,9l 85KW TDI

For me it is not clear. I would expect as first row second line. Then 3, 4 and at last row 1. Pls. correct me if I am wrong. Is there a possibility how to sort in the way I expect? Or I am wrong

Any input is welcome.

Thanks in advance.

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi

In the input help, the values are arranged/sorted in ascending order. Sorting is possible either ascending or descending, but as per your request you want to see the results in the following manner, which is not possible.

12 R4 1,9l 55KW TDI

12 R4 1,9l 63KW TDI

12 R4 1,9l 85KW TDI

12 R4 1,9l 118KW T

Regards,

Raj

Former Member
0 Kudos

Hello Raj,

thanks for quick reply. Why is it not possible?

55KW is less than 118KW. Or does BW read the complete string?

Any ideas or explonations?

OK - I know that it's not a "huge" problem - but I want to know and understand...

Former Member
0 Kudos

Hi,

Generally sorting does not understand the whole unit conversion and so on to keep 55 as less than 118. It only reads digit by digit and at the first occurance of the digit getting less it would move to the first place and continue with the other digits.

A simple solution to understand this more in details would be to copy your example values and paste in Excel sheet and sort them. You would understand this better.

Hope this helps,

Raj

Former Member
0 Kudos

Hello Raj,

again thanks for feedback. I made in Excel the sorting (ascending order) and I receive following result:

111 R4 1,0l 53KW MPI

111 R4 1,4l 103KW B

111 R4 1,4l 125KW Bi

111 R4 1,4l 55KW MP

111 R4 1,4l 59KW MPI

The original sorting (how BEx displays) is:

111 R4 1,0l 53KW MPI

111 R4 1,4l 103KW B

111 R4 1,4l 55KW MP

111 R4 1,4l 125KW Bi

111 R4 1,4l 59KW MPI

So line three and four are changed. I get the same result if I remove the last digit(s). Nevertheless from my point of view this is an error. Or if you / someone else got an solution - it would be very helpful.

Thanks in advance.