cancel
Showing results for 
Search instead for 
Did you mean: 

Some EWA not delivered by mail

former_member229542
Active Participant
0 Kudos

Hi Guys

After finishied EWA Configuration, Im experiencing an odd issue, and I could not find the root cause of this

All landscape is included in EWA Service Delivery

All EWA Alerts are properly generated every monday

And in SCOT, all of them except two were delivered by mail

TED, TEQ; PIQ; PID and TSM Early Watch reports were delivered, but PIP and TEP, which are the productive never were sent.

Any idea how to find out what happened an how to resend them?

Is there any log showing why the EWA was generated but not sent?

Best

Martin

Accepted Solutions (1)

Accepted Solutions (1)

ruth_reilly
Active Participant
0 Kudos

Hello Martin,

The following SAP Knowledge Base Article should be able to help you troublehoot further.

1826552 - EarlyWatch Alerts (EWA) reports in Solution Manager 7.1 is not being sent by email.

Best regards,

Ruth

former_member229542
Active Participant
0 Kudos

Hi Ruth, thanks for your help

After validating each step from the note, I found out job SM:EXEC_SESS_5_5000000000131, which is the one with the ID corresponding to PIP EWA alert, is cancelling with the following dump

Category               ABAP Programming Error

Runtime Errors         DATA_OFFSET_NEGATIVE

Except.                CX_SY_RANGE_OUT_OF_BOUNDS

ABAP Program           SAPLDSVAS_HTML

Application Component  SV-SMG-SVD-SWB

Date and Time          13.10.2015 16:22:06

Short text

     Invalid subfield access: Negative offset

What happened?

     Error in the ABAP Application Program

     The current ABAP program "SAPLDSVAS_HTML" had to be terminated because it has

     come across a statement that unfortunately cannot be executed.

How to correct the error

    Use a positive offset specification when accessing a section of field

    "LV_HTML".

    If the error occurred in your own ABAP program or in an SAP

    program you modified, try to remove the error.

I have tried to find a note but couldn´t find any relevant. A similar one is 1571555 but it does not apply since System is SP 13 and that note is way older!

Tried to re-execute the job but it keeps failing with the same dump

Do you have any idea how to fix this dump?

Best

Martin

ruth_reilly
Active Participant
0 Kudos

Hi Martin,

I found this SAP Note for SP13 - 2157617 - Dump DAT_OFFSET_NEGATIVE in Job SM_EXEC_MULTI_SESxx

Regards,

Ruth

xlazaro
Explorer
0 Kudos

Thank you very much!

This note also solve my case

Cheers

Former Member
0 Kudos

Thank you, i've got the same problem and it works for me too

Former Member
0 Kudos

In my case, i had not a problem with the job: SM_EXEC_MULTI_SESxx, my problem was to display a previusly created EWA, and this note, solved it!
Thanks!!

Answers (1)

Answers (1)

former_member229542
Active Participant
0 Kudos

Awesome Ruth!

That note fixed the issue, i think due the typo on the Note Title I couldnt find it in Marketplace

Best

Martin

ruth_reilly
Active Participant
0 Kudos

Glad to hear your issue has now been resolved.