cancel
Showing results for 
Search instead for 
Did you mean: 

SMD agent not connecting to the SMD server!!!!

Former Member
0 Kudos

Hi

We are tring to set up the Solution manager diagnostics. We are on SP13 NW04s.

We finished installing the Wily 7.2, Diagnostics System Wizard,

and then finished installing the SMD agent on the remote server without any error.

Our Diagnostic system server(solution manager) in on i5/OS and the our SMD agents are spread across windows servers & i5/OS servers.

The SMD agents from the i5/OS server got connected to the Diagnostic server(solution manager) within minutes.

But the ones from windows(X64) do not get connected to the Diagnostic server(solution manager) . We waited and waited, tried rebooting the agent, but to no help. The status it shows is "in process"

When we checked the logs in the SMD agent system on windows, we found out that it is complaining about some application which failed to unzip as shown:

Mar 18, 2008 8:04:47 PM [Thread[SMDAgent connection thread,5,main]] Info [SMDConnector.reset] in progress ...

Mar 18, 2008 8:04:47 PM [Thread[SMDAgent connection thread,5,main]] Info Stopping Applications ...

Mar 18, 2008 8:04:47 PM [Thread[SMDAgent connection thread,5,main]] Info [SMDConnector.reset] Done.

Mar 18, 2008 8:04:52 PM [Thread[SMDAgent connection thread,5,main]] Info [sapms://<SMD_SERVER_NAME>:8145] Waiting for connection ...

Mar 18, 2008 8:04:52 PM [Thread[SMDAgent connection thread,5,main]] Info [sapms://<SMD_SERVER_NAME>:8145] Checking server availability...

Mar 18, 2008 8:04:53 PM [Thread[SMDAgent connection thread,5,main]] Info [sapms://<SMD_SERVER_NAME>:8145] Authentication in progress ...

Mar 18, 2008 8:04:53 PM [Thread[SMDAgent connection thread,5,main]] Info [sapms://<SMD_SERVER_NAME>:8145] Connection established .

Mar 18, 2008 8:04:53 PM [Thread[SMDAgent connection thread,5,main]] Info [sapms://<SMD_SERVER_NAME>:8145] Registering agent on server ...

Mar 18, 2008 8:04:53 PM [Thread[SMDAgent connection thread,5,main]] Info Reading JStartup environment...

Mar 18, 2008 8:04:53 PM [Thread[SMDAgent connection thread,5,main]] Info 'SAPLOCALHOST' found, The value 'srvlctemp01' will be used to determine the Agent name.

Mar 18, 2008 8:04:53 PM [Thread[SMDAgent connection thread,5,main]] Info InetAddress Resolving for 'srvlctemp01' - FQN: srvlctemp01 SQN: srvlctemp01 IP: 10.10.16.89

Mar 18, 2008 8:04:53 PM [Thread[SMDAgent connection thread,5,main]] Info InetAddress Resolving for localhost - FQN: srvlctemp01 SQN: srvlctemp01 IP: 10.10.16.89

Mar 18, 2008 8:04:53 PM [Thread[SMDAgent connection thread,5,main]] Info Agent handle : srvlctemp01_SMD_J66/srvlctemp01 created.

Mar 18, 2008 8:04:53 PM [Thread[Thread-620,5,main]] Info Overriding runtime property from server configuration, name= 'runtime.states.initial', value='core.startup,core.patch.enabled'.

Mar 18, 2008 8:04:56 PM [Thread[Thread-616,5,main]] Info [AgentContext.offlineDeployApplicationConfiguration] ENTERING

Mar 18, 2008 8:04:56 PM [Thread[Thread-616,5,main]] Error Deploy application configuration failed.

[EXCEPTION]

com.sap.smd.agent.deploy.DeploymentException: Cannot expand zip entry.

at com.sap.smd.agent.deploy.DeploymentManager.extractCompressedStream(DeploymentManager.java:258)

at com.sap.smd.agent.deploy.DeploymentManager.installAppConfiguration(DeploymentManager.java:780)

at com.sap.smd.agent.AgentContext.offlineDeployApplicationConfiguration(AgentContext.java:597)

at com.sap.smd.agent.AgentContextp4_Skel.dispatch(AgentContextp4_Skel.java:189)

at com.sap.engine.services.rmi_p4.DispatchImpl._runInternal(DispatchImpl.java:313)

at com.sap.engine.services.rmi_p4.DispatchImpl._run(DispatchImpl.java:199)

at com.sap.engine.services.rmi_p4.DispatchImpl.run(DispatchImpl.java:710)

at java.lang.Thread.run(Thread.java:534)

Caused by: java.util.zip.ZipException: invalid entry CRC (expected 0x0 but got 0x1b3304ba)

at java.util.zip.ZipInputStream.read(ZipInputStream.java:164)

at com.sap.smd.agent.deploy.DeploymentManager.extractZipEntry(DeploymentManager.java:321)

at com.sap.smd.agent.deploy.DeploymentManager.extractCompressedStream(DeploymentManager.java:251)

Has anyone experieced any kind of errors related to this?

Thanks

View Entire Topic
FredericOzon
Employee
Employee
0 Kudos

Hi,

Deploy LMService NW04s SP13 patch 4, this issue is solved in it.

Regards,

Frederic

Former Member
0 Kudos

Hi Frederic.

Applying the LMService NW04s SP13 patch 4, solved the issue immediately.

though I couldn't open the SAP note associated with it.

Anyway, thanks a lot for the advise.Now I gotta configure the Managed System and the Introscope agent and we are done..:))..if everything goes all right and no more bugs...

Thanks

Former Member
0 Kudos

Hi Folks,

Can u give me the steps and best practices to be follow to configure & Install the WILY Interoscope with solution manager.

Please share your experience also with WILY Interoscope.

Documents would be highly appreciated with reward points.

Regards,

Akshay