Showing results for 
Search instead for 
Did you mean: 

smartform: Please maintain an output device in your user master data

Former Member
0 Kudos

I am using smartforms to send an email. If I remove the printer from my master data and I run my program in the background, I get the error 'Please maintain an output device in your user master data'. If I run it in the foreground I do not get the error. This will be a background job and that user does not have an output device. Here are my output settings.

l_output_options-xsf = 'X'. " XSF Output active

l_output_options-xsfcmode = 'X'. " Get XSF params from program

l_output_options-xsfoutmode = 'A'. " Application

CLEAR l_output_options-xsfoutdev.

l_output_options-xsfformat = 'X'. " Formatting ON

l_output_options-tdimmed = space.

l_output_options-tdnewid = space.

l_control_parameters-no_dialog = 'X'.

Please help!


Accepted Solutions (0)

Answers (4)

Answers (4)

Active Contributor


You need to fill the parameter l_output_options-tddest with the output device when calling the Smart Form function modele. You also need to set the parameter USER_SETTINGS=' '. It is filled with 'X' by default.



0 Kudos

Hi Former Member

Seems like you did not pass your printer device to control parameters

Also there are plenty of threads available in SCN regarding this error , just go through it you will get it sure




Active Contributor
0 Kudos
0 Kudos

Hi Brent,

It is quite logical that we need to some place/location where we can save the output. so we need output devide. if user doesnot have output device, who will go and gove him the printout of smartform output