cancel
Showing results for 
Search instead for 
Did you mean: 

Smart Browser Support Netscape / Mozilla

Former Member
0 Kudos
293

Hello,

in SAP Presentations about web dynpro you can learn that client side rendering will work for

those smart browsers that support the html dom object model.

We wrote some applications build with the Develloper Studio that came with the Sneak Preview in May 2003.

Web Dynpro works fine with IE 5.5+. But trying the same application with a new Mozilla version, we get a lot of javascript errors. So in that version, the Client Side Framework doesn't work on Mozilla.

So my question is:

Is Netscape/Mozilla supported in the final versions shipped this year?

Thanks in advance,

Ulf helmke

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Karin,

thanks for the info. We are running Developer Studio 2.0.4, build id 200401230510. We recieved the CDs from SAP directly. It says "Final Release" on the splash screen when Eclipse starts up, but the CD has the words "Test version" printed on it.

Do you know if this build we are running is Sneak Preview II or some other version?

Many thanks,

Jake

Former Member
0 Kudos

Hi Jake,

Sorry for the delay.

Sneak Preview II has not been delivered on CD. So that must be a different version. Only Sneak I or the 6.30 ramp-up version are available on CD. The latest version really is Sneak Preview II which you can download from the Download section here at SDN.

Hope this helps,

Karin

Former Member
0 Kudos

Is Netscape 7.1 supported for Netweaver '04? Or just Netscape 7.0? And is Mozilla on the map for any future releases?

Thanks,

Jake

Former Member
0 Kudos

Hi Jake,

I tried a simple Web DynPro sample from Sneak II (WAS 6.40) with Mozilla 1.6 and it works (in difference to Sneak I, WAS 6.30b2)

HTH,

Andrees

Former Member
0 Kudos

Hello All,

With Sneak II we support IE >= 5.5 und NN 7.0.

NN 7.1 is not supported. Because of the affinity between Netscape and Mozilla, the app could run there as well, but it is not officially supported. With Sneak I we did not support NN at all.

Best regards,

Karin

Former Member
0 Kudos

Hi Ulf,

With SAP NetWeaver '04 we support Netscape 7.0.

Best regards, Karin