Showing results for 
Search instead for 
Did you mean: 

SLDAccess set to true, but not available with PI 7.10 SPS 7

Former Member
0 Kudos

Hi all,

strange things happened to me after SPS 7 installation on our PI 7.10 system. In a first check several problems (and bugs) I had were resolved with the implementation but then I found that anything is wrong with the access to the SLD.

When trying to open a for example communication channel the error attached appears: unable to find associated sld element for specified class.

SLD itself looks good so far.

When trying to open the cache status overview inside the integration builder an error occurs telling that the name of the central AE could not be determined:

Unable to determine the name of the central Adapter Engine from the System Landscape Directory at this time. Notifications to the central Adapter Engine are therefore listed using the technical name of the Adapter Engine. This is usually structured as follows: af.<SAP System ID>.<Name of application server>

Inside the SLD the CIM classes are available.

When then trying to repeat cache update for a selected instance the following error occurs: No SLD elements of type SAP_XIAdapterFramework found

Inside the SLD settings the parameters for UnicodeGatewayRegistrationId and NonUnicodeGatewayRegistrationId had been missing after the SPS 7 implementation. I added them with SLD_UC and SLD_NUC again manually so rz70 works fine now.

The transaction sldcheck was red. The reason was that the user had not the needed permissions to access the SLD (but it worked fine with SPS 6).

But this did not wolve the problem for message processing and inside the IB.

When trying to process a message the following error comes up: SLDAccess set to true, but not available.

So quite strange but everything I checked did not give me a hint of what is wrong.

Roles are new generated.

Users are not locked.

System restarted several times after changes.


Anybody with a similar problem so far or any kind of an idea?

BR Markus

Accepted Solutions (0)

Answers (5)

Answers (5)

Former Member
0 Kudos

Hi all,

verry good suggestions. The note solved my problem, nearls ;-).

How it came to this?

It has been a propper installed and working PI 7.10 SPS 6.

After or during patching to SPS 7 anything went wrong in communication with the SLD. During investigation the user registering to the SLD was not allowed to do this any more and the entries inside SLD Administration for the two RFC connections were not available any more:

1. SLD setting: NoneUnicodeGatewayRegistrationId for SLD_NUC was gone (deleted during patch)

2. SLD setting: UnicodeGatewayRegistrationId for SLD_UC was gone (deleted during patch)

3. SLD setting: StartRfcServer for true was gone (deleted during patch)

4. User for SLD access was not alowed to access SLD

This Blog is quite good /people/venugopalarao.immadisetty/blog/2007/03/15/adapter-engine-cannot-be-found-in-integration-directory but did not fit 100% my problem as well.

The problem on my side was based on the fact that my system was upgraded from PI 7.00. It looked like that the users had not all permissions needed for a PI 7.10 system with SPS 7. I changed the permissions of the following users: PIRWBUSER, PIREPUSER, PIDIRUSER, PIAPPLUSER und PIAFUSER and added the following roles but I think that the main role is this one: SAP_BC_WEBSERVICE_PI_CFG_SRV











Maybe I will check later which one was really the reason for my problems.

BR Markus

Former Member
0 Kudos



If you have any error in sldcheck means follow this



Active Contributor
0 Kudos


This error is caused by inconsistensy in sld.If the technical system and the business system are not installed properly, Instead of following sap note 764176 , better you follow the steps in the blog suggested by Sunil. This should solve your problem. After following all the steps perform Clear SLD data cache under Environment in directory. It will take little time to reflect.Check also the cache notifications these should be all green.


Active Contributor
0 Kudos

HI Jan-Markus,

I have come across this problem, and i have managed to get rid of this problem

by implementing the note 764176

later i have found that there is a blog available on this (coz this is commonly faced problem)



Sunil Singh

Former Member
0 Kudos

Roles are new generated. -

did you compare the roles in PFCG?

Regarding SLDCHECK is red.

besides RZ70, please check t-code sldapicust, sm59,

and JCO, SLD data provider in Visual administrator.

and check note 1117249.

Edited by: Shen Peng on Jan 16, 2009 11:11 AM