cancel
Showing results for 
Search instead for 
Did you mean: 

SLD_UC not registered

Former Member
0 Kudos
11,779

I am trying to configure my ABAP server to act as the data supplier for my SLD installed on an J2EE server.

I configured my ABAP server using RZ70. When I test "SLD_UC" in SM59 I get the error message below:

Connection Error

Error when opening an RFC connection

ERROR: program SLD_UC not registered

LOCATION: SAP-Gateway on host M2003173DVM / sapgw00

DETAIL: TP SLD_UC not registered

COMPONENT: SAP-Gateway

COUNTER: 2

MODULE: gwr3cpic.c

LINE: 1778

RETURN CODE: 679

SUBRC: 0

RELEASE: 700

TIME: Tue Jun 10 09:16:05 2008

VERSION: 2

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

when navigating to SLD->Administration->Data Supplier I get the result below:

RFC server threads:

[DOWN] JCO/RFC server threads

Gateway Host:

Gateway Port:

[UP] BuilderDirector version 1.0.1

Updated SLDs:

(local) sld/active

Supported data types:

BCSystem

J2EESystem

ComputerSystem

Generic (sldreg)

Last data received: J2EESystem at Tue Jun 10 09:15:00 EDT 2008

Current data queue size: 0

Former Member
0 Kudos

Check all the settings using SLDCHECK....

use this note 1057720

rewert back if any problems

Former Member
0 Kudos

thank you for the note. SLDCHECK is for XI - I do not have XI, so I dont see how the note applies to my case. Any other ideas?

Former Member
0 Kudos

Then I would say is to create a JCO rfc with the name SLD_UC from your Java system pointing to ABAP system.

And put the entry of Java system like System name and gateway value is SLD_UC rfc.

Your rfc problem would be solved.

Former Member
0 Kudos

Hi Deepak, I am trying to connect my ABAP system to my Java system, not my Java to my ABAP. Let me know.

Former Member
0 Kudos

To connect from ABAP to java you need a registered program (means a program that is running in Java end and recognised by ABAP). So when we create a JCO RFC it would be recognised by ABAP system.

Please read this

http://help.sap.com/saphelp_nw04/helpdata/en/6a/82343ecc7f892ee10000000a114084/frameset.htm

I think this one would clear the idea.

Former Member
0 Kudos

Hi Deepak, thank you for the suggestion. I tried it and it resolved my problem.points awarded accordingly.

Former Member
0 Kudos

Hi All,

Sorry to continue on this Thread... but today i too got this problem & as suggested here, i did created SLD_NUC JCO RFC provider in my SLD System. Now my RFC is working fine, but when i run Data supplier job through RZ70, it is giving me error of "JCO.Server could not find server function 'SET_SLD_DATA'".

Please find the logs of same & advice me what can be done. I did removed this entry, but then this RFC fails.

SLD DS Start Program

0: inmumsap18_BW2_00 : Execute program: SLDRFC

0: inmumsap18_BW2_00 : Execute program: SLDMSGSRV

0: inmumsap18_BW2_00 : Execute program: SLDIPSERV

0: inmumsap18_BW2_00 : Execute program: SLDINSTSP

0: inmumsap18_BW2_00 : Execute program: SLDINSTSC

0: inmumsap18_BW2_00 : Execute program: SLDINSTPRD

0: inmumsap18_BW2_00 : Execute program: SLDGWSRV

0: inmumsap18_BW2_00 : Execute program: SLDDBSYS

0: inmumsap18_BW2_00 : Execute program: SLDCOMPSYS

0: inmumsap18_BW2_00 : Execute program: SLDCLIENT

0: inmumsap18_BW2_00 : Execute program: SLDBCSYS

0: inmumsap18_BW2_00 : Execute program: SLDAPPL_SERV

0: inmumsap18_BW2_00 : Execute program: SLDASSOC

0: inmumsap18_BW2_00 : Collection of SLD data finished

0: inmumsap18_BW2_00 : Data collected successfully

0: inmumsap18_BW2_00 : RFC data prepared

0: inmumsap18_BW2_00 : Used RFC destination: SLD_NUC

0: inmumsap18_BW2_00 : RFC call failed: JCO.Server could not find server function 'SET_SLD_DATA'

0: inmumsap18_BW2_00 : Test mode: No batch job created

TomCenens
Active Contributor
0 Kudos

Hello

I know this question is answered but in reply to the last issue reported:

The following SAP note provides information in case you would connect an ABAP only SAP system to a JAVA SLD through RZ70:

https://service.sap.com/sap/support/notes/1057720

You should not create JCO RFC destinations in the JCO/RFC Provider in the visual administrator, those will break the process.

Normally the RFC's are auto generated in the Java part and your SLD push in RZ70 will work.

I advise you to run SLDCHECK in the ABAP part if it's not the case and check the logs of the JAVA part for errors (possible under cluster/server0/log/system as you might have authorization issues).

Also the profile settings of the JAVA SLD have to be correct (hostname+gateway).

Kind regards

Tom

Farid
Active Participant
0 Kudos

Hi,

thank you Tom for your input. I had the same issue .

I was about to create manually the JCO destination, when I saw your blog.

I updated the CR_CONTENT in the SLD, and now it works

Thanks

TomCenens
Active Contributor
0 Kudos

Hello Raoul

Thanks for letting me know the blog was useful. Since I noticed so many posts on the SLD_UC issue I decided to place the how to in a blog because it does seem a bit strange when you look at how the configuration is partially auto-performed it causes confusion.

If anyone else bumps into the issue, you can check my blog on how to push ABAP system data to a Java only SLD:

/people/tom.cenens3/blog/2011/02/23/how-to-push-abap-system-data-to-a-java-only-sld

Kind regards

Tom

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi,

Log on to the SLD through the URL http://<hostname SLD>.<domain>.<ext>:5<instance number>00/SLD using a user that has administrative rights (SLDDSUSER if sufficient rights or Administrator).


Now go to Administration--> profile--> select "Data suppier" in parameters dropdown--> enter "gateway host" & " gateway service" here


Now save the data and then restart the SLD and check SLD_UC and SLD_NUC in gateway system logedon cliets list.


If they appear... run RZ70 once again and issue will be resolved.


vijendar

Former Member
0 Kudos

Hello,

SLDCHECK is not just for XI. SLDCHECK tests connectivity between the ABAP Stack and the SLD, it verifies configuration of RFC, SLDAPICUST and RZ70.

I would run SLDCHECK and follow the steps in the troubleshooting note mentioned above.

Regards,

David

Former Member
0 Kudos

Hi David,

when I run SLDCHECK it tells me that the SAPSLDAPI and LCRSAPRFC RFC destinations do not exist. I am not sure I need these destinations for automatic data supplying the ABAP technical info to my Java SLD system. I say that because I have another ABAP system that is connecting fine to a double-stack SLD and I don't have those RFCs in. Only the SLD_UC RFC is required to connect an ABAP system with an J2EE system.

Let me know.