Showing results for 
Search instead for 
Did you mean: 

% sign not displayed in the Bex query report

0 Kudos

Hi All,

I am creating a formula variable and want '%' sign to be displayed at the end of the formula(for example if the value is 60.45 i want it to be displayed as 60.45%).I am using the function ''%A " in the formula .

(ABS( 'a1' ) * SIGN (('a1' * 'a1'))) %A 'a1'

This formula is defined in the row structure ,the query has both row and column structure.

I can see the same formula working in other system and even checked the properties ,everything is the same but here the % sign is not displayed.

I also removed the flag 'Display scaling factor for key figure' .Even tried by removing the scaling factor .And also tried replacing %A with '%A100' but that's showing a syntax error.

Could anyone please let me know if they are any other settings in order to display the % sign in the report.

Thanks in advance.

Accepted Solutions (0)

Answers (1)

Answers (1)

Active Contributor
0 Kudos


I assume that your result is always less than 100, for example result = 60.45. If my assumption is incorrect, please say so. Otherwise do this:

(ABS( 'a1' ) * SIGN (('a1' * 'a1'))) / 100 %A 1