Showing results for 
Search instead for 
Did you mean: 

SIA not connect CMS after update from BO4.0SP5 to 4.1SP6

Former Member
0 Kudos

I have a problem after update from BO 4.0 SP5 to 4.1 SP6

I did the update process as this guide say and followed this note 1909881 - How to upgrade from one version of BI4 to another.

The process finished well, didn't give me any error, but then i try to log in on CMC o BI launchpad and it doesnt work, it gives me this message

Also i check eventviewer on windows and any time i start SIA give me this message

Server cms_.CentralManagementServer

Name Service Port

Published Addresses: :6400.

Listening on port(s): :6400.

Failed to listen on port(s): :6400

I tried restarting server and using another port and its still the problem, i checked and the port 6400 is not used by another service, on BO 4.0 it was all working fine, but after update to 4.1 SP6 is not working, SIA is green at CCM as if it was runing but is not connecting to CMS.

Please help me with this.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Jose,

There are many issue regarding the upgrade i.e. when customer upgrade to BI 4.1 SP6 the SIA is not created, CMS is not running, unable to login etc.

Follow Below steps :

  • Firstly check CCM and check SIA is running if it is running then open Task Manager and check CMS.EXE is running or not. If not that means the SIA is running but no CMS.
  • Then Stop the SIA and go to properties of SIA. Click on each Tab and in configuration tab you should get any error like : Failed to retrieve cluster name or the database section will be blank.
  • If you encountered above error then simply update the Database setting using Specify button in Configuration tab and observe if it retrieves CLUSTER Name just below or else it will say "CMS BELONGS TO NO CLUSTER"
  • If you get this error then simply copy SQLRULE.dfa and SQLRULE.LLR file from working BI 4.1 SP6 environment and place it to same location in problematic environment in win64_x64 folder.
  • Restart the SIA.

Please let me know if that works.



Former Member
0 Kudos

Hi, Thank you so much, i was trying many things and i found out it was a problem with the user that runs the SIA service, initially it was with LocalSystem, and it was failing, after that i tried with the local Administrator, but also had the same problem, after some reading i did notice that there was a Domain administrator, so i tryed with it and it works perfectly. Also i found something about the Auditing difolder, it has more than 13K files, so i moved them to other disk and it worked, SIA started well.

Thank you all for your help.

Answers (2)

Answers (2)

Former Member
0 Kudos


Even though SIA is up and running did you tried to CMS has started. Check logs in Event viewer (if your deployment is on windows servers). See if you have any error for connecting to CMS database.

**Quick test is to see if you can logon from CCM to manage servers. **

I have noticed that after upgrading to 4.1 SP6, SIA- CMS is losing connectivity from CMS database. I don't recall exact error but complains something like "Failed to get database connection string from the system"

Stop SIA and go to configuration tab, and see it is still connected your CMS database. If you click on specify and update the data source to your existing CMS database.

Once updated, start SIA and allow few seconds for CMS service to start and then try to logon.

Update the thread if this helps fixing your issue or if you noticed the same behavior as I explained so others can benefit for this experience.

Bharath Reddy

Active Participant
0 Kudos