cancel
Showing results for 
Search instead for 
Did you mean: 

Showing US data format instead of UK date format.

Former Member
0 Kudos

Hi All,

Problem description:

Particular field in crystal report showing date in mm/dd/yyyy instead of dd/mm/yyyy

Environment Details:

Product Version: XI 3.1 SP6

Operating System: Windows Server 2003

CMS Database: Oracle 11g

Application Server: Tomcat

Browser version: IE 8

Steps Performed:

1. Crystal Reports reports display dates in the US format instead of UK format.

2. The browser language was set to UK [English]

3. In the infoview preferences the preferred viewing locale is set to Use browser locale but still it is showing the date in mm/dd/yyyy format.

4. If the infoview preferences the preferred viewing locale is set to English(United Kingdom) then it shows correct date format.

4. Launched the infoview in the server machine and it is showing the date in dd/mm/yyyy format

5. Viewed the report from CMC it is showing date in dd/mm/yyyy format and also the preferred viewing locale is set to "Use browser locale"

6. Only in infoview we are getting this issue.

7. The issue is on client machine Windows 7 and IE 8

8. Cleared both IE and java cache but still the issue persists.

9. Sometimes get incorrect date format when no SSO is used

10. When SSO is used it does show the incorrect date format

11. Checked with enterprise user from server machine it is showing date in dd/mm/yyyy format.

12. With firefox browser also it is showing incorrect date in mm/dd/yyyy format.

Please suggest.

Thanks,

Rahul Wagh

Accepted Solutions (0)

Answers (2)

Answers (2)

former_member230846
Contributor
0 Kudos

Hi Rahul,

- Does this behavior happen to all date fields?

- Is the field in question a formula field, where you've hard coded it to display dates in a specific format?

I would suggest testing with a simple report,  with just a date type field on the report. 

Regards,

Wallie

Former Member
0 Kudos

Reboot the Windows server and restart BO Servers.