cancel
Showing results for 
Search instead for 
Did you mean: 

Service Maintenance is empty + error in call

Former Member
0 Kudos

Hi

The gateway has the software component IW_BEP installed.

I have created a gateway project, and activated/generated the model, but my "Service Maintenance" is empty.

In tcode /IWFND/MAINT_SERVICE there is a greenlight for my ODATA (in the left side)

In the right side, I see my SAP System, where I want to connect.

When I press the "Call Browser" in the right side, I am calling this URL: http://xxxxxxxx.xxxx.xx:XXXX/sap/opu/odata/sap/ZGW_TEST_SRV/?$format=xml

and got this message:

<error>

  <code>/IWFND/CM_COS/064</code>

    <message xml:lang="en">

      No System Alias found for Service 'ZGW_TEST_SRV_0001' and user 'XXXXX'

    </message>

      <innererror>

         <transactionid>4D29EDE2FB7FF13E8138005056B85277</transactionid>

         <errordetails/>

      </innererror>

</error>

Anyone, who can help me?

In SPRO on gateway, I have done a check of SAP system aliases, and I got this warning:

Assigned WS System - "No WS Provider System assigned"

I don't know if this is relevant.

Path is SAP NetWeaver - Gateway - Former Development - Generic Channel - Configuration - Connection Settings - SAP NetWeaver Gateway to SAP System - Check SAP System Aliases

According to this link:

http://help.sap.com/saphelp_gateway20sp04/helpdata/en/16/81199a1cbf4cd6969295a4db3725c6/content.htm

I can generate a BOP, but the described path in the documentation is not in our system.

Could that be the problem?

The search didn't give any helpful (for me) results:

http://help.sap.com/saphelp_gateway20sp04/helpdata/en/64/472d8e21a342ba9d83e403ff4cd9db/content.htm

Hope someone can and will help me.

Regards

Aikon

View Entire Topic
former_member184867
Active Contributor
0 Kudos

Hi Aikon,

the Service Maintenance becomes empty in if the HUB systems are not configured to the system with IW_BEP component.

You need to configure these from SPRO. There is a shortcut to find the SPRO  path--> a. Click on the 'System'  (highlighted below)

b. Press on F1(help)  c) In the help documentation there is a link to the SPRO path.  Now you  need to configure the systems here,

Once systems are configured you need to reload the SEGW transaction , then you can see the registered systems under service maintenance node in SEGW.

Regards,

Atanu

Former Member
0 Kudos

Hi Atanu

Thanks for your reply - and you were right, that something was missing.

I went through this guide

http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/b054074c-d6cf-2e10-8e96-f81869792...

But even after reloaded SEGW + als tried to create a new project, I don't have any entries in the folder "Service Maintenance" .

Regards
Aikon

former_member184867
Active Contributor
0 Kudos

Hi Aikon,

did you follow the steps that I mentioned in my previous reply ?

If you do so the gateway hub systems will appear in Service Maintenance.

Please see the link for details http://help.sap.com/saphelp_gateway20/helpdata/en/ca/77ae82deed4eba8e02ee4a3d80d267/content.htm

Regards,

Atanu

Former Member
0 Kudos

Hi Atanu
You are so right - I missed one of the entries.
Thanks for your help.

Regards
Aikon

RAHUL1221
Explorer
0 Kudos

Hey guys,
could you pls share the links again as it seems to be broken.

Thanks,

Rahul