cancel
Showing results for 
Search instead for 
Did you mean: 

Server SIde Trust - Unable to load sapcrypto.dll

casey_burkett
Explorer
0 Kudos

Hello -

We are attempting to use Server Side Trust in order to take advantage of publications (Webi) with BW row level security, but it is failing. The server is Windows (64 bit), and we are using sapcrypto. I see this in the logs on the Business Objects server:

-


Tue Oct 12 15:57:09.280 ThreadID<5384> SAPMODULE : Unable to connect to SAP BW server Connect to SAP gateway failed

Connect_PM GWHOST=xxxxxxx, GWSERV=xxxxxxx, SYSNR=xx

LOCATION CPIC (TCP/IP) on local host with Unicode

ERROR Unable to load the GSS-API DLL

named "C:\Program Files (x86)\SAP\Crypto\sapcrypto.dll"

TIME Tue Oct 12 15:57:09 2010

RELEASE 710

COMPONENT SNC (Secure Network Communication)

VERSION 5

RC -1

MODULE sncxxdl.c

LINE 342

DETAIL SncPDLInit

SYSTEM CALL LoadLibrary

COUNTER 1

Tue Oct 12 15:57:09.280 ThreadID<5384> SAPMODULE : Call to m_pRfcWrapper->RfcOpenEx() took 0.000 seconds

Tue Oct 12 15:57:09.280 ThreadID<5384> SAPMODULE : Unable to authenticate using SNC because the URI does not meet the minimum connection requirements.

Tue Oct 12 15:57:09.280 ThreadID<5384> SAPMODULE : Warning: SNC was enable and failed. The authentication process is falling back to secondary Credentials...

-


Entries have been added for the "Path," "SECUDIR," and "SNC_LIB" environment variables. I have reviewed the configuration on the BOBJ side several times...Does the error above mean that the problem is on the Business Objects server??

Thanks for any help...

Casey

Accepted Solutions (1)

Accepted Solutions (1)

IngoH
Active Contributor
0 Kudos

Hi,

did you try to use the 64bit version ?

ingo

casey_burkett
Explorer
0 Kudos

Hi Ingo --

That is the 64 bit version, but I didn't even think about it until you asked that question. I'm guessing you're going to tell me that we need to re-configure everything from "Program Files" rather than "Program Files (x86)" since it is 64 bit?

Thanks!

Casey

IngoH
Active Contributor
0 Kudos

Hi Casey,

64bit on the SAP system

32bit on the BOBJ system

Ingo

casey_burkett
Explorer
0 Kudos

Thanks Ingo. Looks like that fixed it.

casey_burkett
Explorer
0 Kudos

Ingo -- I was able to create and run publications as well as schedule reports using SNC Friday after changing the dll, but they started failing shortly thereafter with these errors:

Scheduled Reports (Webi) - "Unable to reconnect to the CMS SERVERNAME:6400. The session has been logged off or has expired. (FWM 01002)"

Publications - "An exception was caught while scheduling the publication. (FBE60203)" and "Unable to find the publication artifact with ID ###### during distribution. (FBE42045)"

What I find strange is that I am able to run the Webi without a problem, but when I attempt to schedule it, I get the error above. Any ideas?

Thanks

Casey

IngoH
Active Contributor
0 Kudos

Hi,

so does that happen with all scheduled reports ?

Ingo

casey_burkett
Explorer
0 Kudos

Hi Ingo -

We have a 3 node cluster, and it looks like the scheduled reports succeed when they use the Adaptive Job Server on node 3, but any scheduled reports/publications that failed show one of the other two nodes for "Server Used".

Thanks again for your help.

Casey

IngoH
Active Contributor
0 Kudos

Hi,

do they all have access to the libraries and run under the ncessary account ?

Ingo

casey_burkett
Explorer
0 Kudos

Yes, they are all running under the same account which has access to the files. Just to be clear....there is a copy of the files on each server in the cluster, and the domain user that is running the SIA service has been given access to the PSE file one each server. I can see in the MDA logs of each server that SNC is being used successfully when Webi reports are run.

Thanks

Casey

casey_burkett
Explorer
0 Kudos

Ingo,

Any other thoughts?

Thanks

Casey

Former Member
0 Kudos

Hi Casey Burkett ,

We are experiencing same issue. Have your issue fixed?

Thanks,

Kiruba v.r.

Answers (0)